YamlValidationException: Failed to validate domain file

I am facing below error when I train rasa, error : Please make sure the file is correct and all mandatory paramet ers are specified. Here are the errors found during validation

i have attached my domain file

and it gives nothing about errorsdomain.yml (13.6 KB)

1 Like

Hi @sakar, you can use https://yamlint.com to validate your domain file. It will process the file and also make some formatting changes. Double check after you validate the domain file.

Thanks for replying @ChikkaUdayaSai but i already validated domain file on that website. It says valid there but here in rasa it gives error.

Hey @sakar, Can you post the errors here?

@ChikkaUdayaSai please see the error, it just says Please make sure the file is correct and all mandatory paramet ers are specified. Here are the errors found during validation.

and shows nothing.

Okay. I guess it’s more like a whitespace issue. While writing domain file, we should not use space. We have to use tabs. Can you check any whitespaces are there in your domain file.

I will give overview of my project so that you can understand more,

I am building a bot which answers python questions means someone wants to learn python then bot can teach him. learner will ask questions like what is list, what is tuple ,show me list program, show me for loop program.

so when, for loop program will come then bot answers should consist indentation, so what should I do in that situation I used “\n” for new line and “\t” for tabs but that tabs are too long, it make program doesn’t follow pretty printing.

I saw old version just used " > " operator and outputs programs nicely but I don’t think new version supports “>”.

it would be very great help if you suggest any idea to such scenario.

Hi @sakar, I am more active on LinkedIn. I am from IST. So, kundly reach out to me in case of any help.

Uday

Please send me a personalized invite in Linkedin so that I can accept your request.

Hi @sakar I am getting the same error. Have you been able to solve it ?

1 Like

Hi! I have the same problem too. Did you learn how to fix it? Thanks :))

no

I got the same error now, what is happening with the domain D:

@sakar Is this problem solved? If so, please share the solution. I have the same problem

I had the same problem. And the cause of that problem was the image tag in YML domain file. The image tag had an incorrect image url (was not pointing to the image actually). When i removed the whole image tag from the file the problem got solved!! The yml file is probably is failing in runtime because of this!!!