Specified Errors on Training Not Specified

So I tried to retrain my bot after adjusting some intents and the domain file and I got the following error:

YamlValidationException: Failed to validate ‘C:\xxxxx\domain.yml’. Please make sure the file is correct and all mandatory parameters are specified. Here are the errors found during validation…

And then it does NOT list ANY errors. I checked my domain.yml in http://www.yamllint.com/ and it says it’s fine. I also upgraded to the latest version of rasa.

I also get some warnings regarding tensorflow that look like this but I am not sure it’s related…

2021-02-19 16:24:20.355775: W tensorflow/stream_executor/platform/default/dso_loader.cc:59] Could not load dynamic library ‘cudart64_101.dll’; dlerror: cudart64_101.dll not found 2021-02-19 16:24:20.355899: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine. 2021-02-19 16:24:22.253514: I tensorflow/stream_executor/platform/default/dso_loader.cc:48] Successfully opened dynamic library nvcuda.dll 2021-02-19 16:24:22.275309: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1716] Found device 0 with properties:

Any one have any thoughts on what’s going on?

Thanks, Jordan

Regarding the tensorflow errors it tells you right here that these are safe to ignore if you don’t have a machine with a GPU:

Could you share your domain.yml here? The error is suggesting that some mandatory parameter is missing. If your domain file is getting longer than before and you’re afraid the YAML might get messed up, consider using Multiple Domain Files as shown in the docs here: Domain.

Hey Shorouq, So my domain file is not separated yet, but it’s not so large at this point.

I took a closer look at the domain file and noticed that some syntax had changed some how. I am not sure if this is a result of updating rasa or when I installed and ran rasaX for the first time. But things that looked different are:

All my intents have a new line "use entities: true: " after the intent name.

For an utterance that has a second and third line I remember using \n to indicate the new line but now that line is written: text: |- First line of dialog Second line of dialog

And finally I see an “e2e_actions:[]” line that I never added or know what it is.

Anyway attached is my domain.yml - Please let me know if you spot anything that might be causing the error. Thanks.

domain.zip (2.1 KB)

This is certainly due to running rasa-x since it reformats your YAML files and adds some things that would be set to that by default if missing.

Is this the same domain file that gets you the YamlValidationException error?

Yes this the same domain file, and I get the exact same errors if I run either rasa train OR rasa x

I can run my previously trained model using rasa shell though. Which seems strange.

Not sure if I need to reinstall rasa x or what?

So I am still having this problem. :frowning_face:

I even created a new virtual environment and reinstalled rasa, copied my files including the domain file, and retried rasa train and still I get this glorious error :

YamlValidationException: Failed to validate ‘C:\xxxx\bots\xxxx\domain.yml’. Please make sure the file is correct and all mandatory parameters are specified. Here are the errors found during validation

And no list of errors ever follows. I have checked the file in both yamillit and yaml checker and they both say it’s valid. What gives? What am I missing?

Any help or suggestions would be greatly appreciated. :slightly_smiling_face:

Have you been using version control? Can you find the domain file you used before running Rasa X which modified your domain file?

Unfortunately no, I have not been using version control. This was the beginning of building the bot and I am doing everything locally. Putting stuff up on git was on my list.

I have seen a few other posts regarding this or similar issues but no solutions. Off the board someone mentioned that my version of rasa x might be incompatible with the version of rasa open source I am using but I was under the impression I was using the latest for both.

You should check the compatibility matrix.

What are your rasa x and rasa versions? Are you using the rasa-sdk as well?

1 Like

So yes there is currently a compatibility issue. (thanks for sending that link btw). I am running 2.3.2 of rasa open source, and 0,35 of rasa x.

However I was actually able to edit the domain file in order to train and run rasa x again but of course rasa x re-wrote my domain.yml again (but I have a back up now). To make it run I edited the changes that were made to the intents plus a few other things I saw that I remembered to be different.

- affirm:
    use_entities: true
- appreciate:
    use_entities: true

Editied back to :

intents:
- affirm
- appreciate

Regardless I will update my rasa x version and see what happens! Thanks again.