YamlValidationException: Failed to validate the domain file

I am facing below error when I train rasa, error : Please make sure the file is correct and all mandatory parameters are specified. Here are the errors found during validation

i have attached my domain file and it gives nothing about errors

domain.yml (23.9 KB)


Try correcting the line 9 ‘yes’ its in a different format than others.

Hello @khushboo_kumari and welcome to the forum!

I have seen you domain.yml it have 59 issue, you can check your file on http://www.yamllint.com , you just need to copy the code and paste it and hit go.

I’d highly recommend to please see all the syntax and codes on rasa docs: NLU Training Data

Further, read the error twice. It only has the solution mentioned.

Please read the forum rules and working method. Thanks.

1 Like

@khushboo_kumari Is this issue solved? If solved can I request to please close this thread as a solution? Thanks.

Yes it has solved as some syntax errors in the nlu.yml file. Thankyou