Wrong Credentials Error when trying to setup Rasa X with Docker Compose Quick-Install

Hello everyone.

I am trying to setup Rasa X on ubuntu server. I have done all the steps described in the docs and blog, but I get the Wrong Credentials error when I use the admin password specified in the step 3 to sign in.

What am I missing or doing wrong? Am I supposed to make additional manual configs in the /etc/rasa ? If so, what am I supposed to do?

P.S. One more additional question. May I use the same server for hosting both Rasa X and Rasa api?

If you ran sudo python rasa_x_commands.py create --update admin me <PASSWORD> and used “me” as the user when logging in then no, you shouldn’t have to configure anything else. You could re-run it to make sure you’re using the same password/username when logging in.

May I use the same server for hosting both Rasa X and Rasa api?

Deploying Rasa X already deploys Rasa; by using the Rasa X API, you’ll be connecting to the running rasa instance too (depending on what API call you’re making).

@mloubser I did use “me” in that command for creating password. So that meant “me” was the root user?

Also, I don’t get it when you say

and used “me” as the user when logging in

Where could I use that during sign in? This is the page that opens at my http://my_hostname/login page

I type the password specified with the command you mentioned and it gives me this error. I have checked the password and have rerun it several times. Still gives the error :confused:

After the docker-compose installation setup I find an /etc/rasa/models directory empty. Is it what was supposed to be? And the endpoints.yml file looks like “empty” too.

Are these issues the reason that prevents me from signing in? What can I do now?

Regarding the api, I use REST api at /webhooks/rest/webhook. I am currently hosting it at the same server as I use it from back-end side.

Yes, it is expected that the model directory would be empty, since you have not yet trained a model. Your endpoints file is fine, those variables are filled by the values in the .env file.

Regarding the api, I use REST api at /webhooks/rest/webhook . I am currently hosting it at the same server as I use it from back-end side.

You mean you are running Rasa, seperately from your docker-compose deployment of Rasa X, and accessing it this way? You can use the Rasa X api to access your deployed Rasa container. If you are trying to connect a channel, you should put your credentials in the credentials file on your server, at /etc/rasa

But how to solve the wrong credentials error? I can’t even enter to Rasa X interface beacuse of that error.

Yes, I am running Rasa separately, without using docker containers (that is another painful story, I couldn’t make it to work in docker container along ducking). It is just hosted explicitly on my server’s specified ports. What are the credentials that you have mentioned? I don’t have any specified ones. I’m sorry, I really don’t get it. Maybe I haven’t used the correct workaround so far.

I would be grateful if you answer the following questions:

  1. How to overcome the wrong credentials error (screenshot in my last message)?
  2. How to use already trained model in Rasa X, which is hosted explicitly on the server and used by REST channel only?
  3. What credentials should I be using that I’m not aware of in the above-mentioned setup?
  4. What is the best setup that I should be using?

Hello, Do you overcome the wrong credentials error?

Nope. Not yet. Do you get the same error?

I deleted GCP VM and created a new one, then followed the instruction " Docker-Compose Quick Install", and it worked. (ps:There is also “Authentication token invalid” error , but after entering the right password there is no “Wrong Credentials” error)

this will work 100%

docker-compose exec rasa-x bash -c “python /app/scripts/manage_users.py create --update me admin”

I was facing a similar issue Updated the password to something that does not contain special charcaters. So now it’s working.