Wrong Credentials Post Rasa X Update


I am a newbie and deployed Rasa X (Google Cloud - Docker) as per this tutorial. Everything was fine and I could chat with the deployed assistant until I got a notification about updating Rasa X.

After updating, I kept getting ‘Wrong Credentials’ when typing my login password (see screenshot below). (NB: The wrong credentials warning pops up automatically even before typing my password)

I went through the other topics and tried all (restarting, resetting using sudo python3 rasa_x_commands.py create --update admin me etc.) but no luck. Anyone else with the same problem?


mhm, that’s weird - what do the logs tell you? E.g. docker-compose logs rasa-x?

Thanks for replying. When I run that command I get this:

BTW, I realized that this forum is for rasa open source so I asked for this topic to be closed and I opened another one at the Rasa X Forum.

Weird - what do your developer tools say in the network tab when you try to log in? And what was the result of sudo python3 rasa_x_commands.py create --update admin me ?

Thanks agin. I get the following:

Wow - this is super weird. Which Rasa X version are you running? Did you you try to restart in between?

Thanks again for replying @Tobias_Wochinger I deleted the Gcloud VM instance and re-did the entire thing and now it’s working. I have no idea why but it seems that the brute force method worked this time.

Ok, glad you got it solved :+1: :grimacing:

Hello Team,

I have been trying to install rasa x using docker compose. I have previously done it many times and have never had the password issue. This time however when I try to set the password as mentioned in the documentation page "sudo python rasa_x_commands.py --update create admin <USER> <PASSWORD>" I’m setting the as admin and I get the below error

"rasa_x_commands.py: error: unrecognized arguments: --update"

Also I had never seen the user name pop up on the login page till date… I am assuming the username to be admin.

I have also tried setting the RASA_X_PASSWORD as,

  1. export RASA_X_PASSWORD=
  2. setting it in the sudo vi ~/.bashrc
  3. also in the /etc/environment file

None of them seem to work for me… Can someone please help me out here? @Tobias_Wochinger


Creation or update cmds are also throwing an error!