Rasa Credentials:

@fkoerner

Wrong Credentials Error:

I installed RasaX using docker, I am currently facing that issue of wrong credentials.

Things I have tried:

cd /etc/rasa
sudo python rasa_x_commands.py  create --update admin me rasarasa

sudo python rasa_x_commands.py --update create admin me rasarasa

sudo python3 rasa_x_commands.py create --update admin system_user rasarasa

[email protected]:/etc/rasa$ sudo docker-compose exec rasa-x bash -c "python3 /app/scripts/manage_users.py create me welcome123 admin --update"
User me does not exist. To create a new user please run `sudo python rasa_x_commands.py create admin me <pw>`

None of them is working, i still get the same error.

This is my installation command

curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/1.0.0/install.sh

@nik202 do you have an idea about this issue?

@atwine try first run the docker container and then set the password and you only need to run this

sudo python rasa_x_commands.py create admin me <pw>

As I can see you are trying to install rasa 1.0.0? Is it?

OR if the issue persists, then I’d recommend to re-install the Rasa X, can you share which installation step you are referring?

I revised my installation and installed using this command instead:

curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/0.42.0/install.sh

RasaX version 0.42.0 works fine, thanks.

Right now my issue is attaching the actions server, its not being seen. Any info on that?

I used docker-compose to install RasaX

@nik202

@atwine Yes, that was my concern as I guess in new documentation this is no docker installation for rasa 1.x, but yes Rasa X 0.42.0 to 0.42.5 will work fine, it will also tempt you to update, please take a wise decision for the same.

You need to create the docker-compose.override.yml and in that, you need to mention the action image, please ref Rasa Master Class Ep:09 (Ep #9 - Rasa Masterclass) Improving the assistant: Setting up the Rasa X | Rasa 1.8.0 - YouTube (12:00 min)

Update it, down the docker and up the docker again

sudo docker-compose down && docker-compose up -d

If you have any permission issue please let me know.

Hey @nik202

I believe I have successfully installed that, here are my settings:

CONTAINER ID   IMAGE                        COMMAND                  CREATED          STATUS                          PORTS                                                                                    NAMES
e3b0ac644922   nginx:1.19                   "/docker-entrypoint.…"   11 minutes ago   Up 3 minutes                    80/tcp, 0.0.0.0:80->8080/tcp, :::80->8080/tcp, 0.0.0.0:443->8443/tcp, :::443->8443/tcp   rasa_nginx_1
89933f362524   rasa/rasa-sdk:2.8.1          "./entrypoint.sh sta…"   12 minutes ago   Restarting (1) 55 seconds ago                                                                                            rasa_app_1
7eea55c1f84d   rasa/rasa:2.8.0-full         "rasa x --no-prompt …"   12 minutes ago   Up 3 minutes                    5005/tcp                                                                                 rasa_rasa-worker_1
b5eedcd7761a   rasa/rasa:2.8.0-full         "rasa x --no-prompt …"   12 minutes ago   Up 3 minutes                    5005/tcp                                                                                 rasa_rasa-production_1
81341162352f   rasa/rasa-x:0.42.0           "python -m rasax.com…"   12 minutes ago   Up 2 minutes (healthy)          8000/tcp                                                                                 rasa_db-migration_1
9cdc7ab2ba84   rasa/rasa-x:0.42.0           "/tini -g -- sh -c '…"   12 minutes ago   Up 3 minutes                    5002/tcp                                                                                 rasa_rasa-x_1
36488fd38a93   bitnami/postgresql:11.11.0   "/opt/bitnami/script…"   12 minutes ago   Up 3 minutes                    5432/tcp                                                                                 rasa_db_1
7e0c9585f515   bitnami/rabbitmq:3.8.17      "/opt/bitnami/script…"   12 minutes ago   Up 3 minutes                    4369/tcp, 5671-5672/tcp, 15671-15672/tcp, 25672/tcp                                      rasa_rabbit_1
447e97f5773e   rasa/duckling:0.1.6.5-r2     "duckling-example-ex…"   12 minutes ago   Up 3 minutes                    8000/tcp                                                                                 rasa_duckling_1
ec172de44867   bitnami/redis:6.2.4          "/opt/bitnami/script…"   12 minutes ago   Up 3 minutes                    6379/tcp                                                                                 rasa_redis_1

docker-compose.override.yml file

version: '3.4'
services:
  app:
    image: 'rasa/rasa-sdk:2.8.1'
    volumes:
      - './actions:/app/actions'
    expose:
      - '5055'
    depends_on:
      - rasa-production

File Structure

[email protected]:/etc/rasa$ ls
actions  certs        credentials.yml  docker-compose.override.yml  endpoints.yml     logs    nginx-config-files  scripts
auth     credentials  db               docker-compose.yml           environments.yml  models  rasa_x_commands.py
[email protected]:/etc/rasa$ cd actions/
[email protected]:/etc/rasa/actions$ ls
actions.py  __init__.py
[email protected]:/etc/rasa/actions$

Now I don’t know what I am missing: The actions, still now running.

Should I install the latest sdk and not 2.8.1?

@atwine This issue can be some missing packages or some error in a code that’s why It show the error, till the time rasa_app_1 stay as UP and Healthy you will not able to use custom action.

Please run the docker using this command and check the rasa_app_1 logs, and check it’s excited with 0 or 1 and the message (share with us)

docker-compose up

Note: Even mention this user: root in docker-compose.override.yml

I’m facing drafts offline issue and IP issue on forum, so my reply can be late.

This is what I see in the logs @nik202

nginx_1            | 168.167.247.8 - - [06/Jan/2022:13:59:05 +0000] "GET /api/projects/default/git_repositories/1/status HTTP/1.1" 200 264 "http://137.63.194.18/interactive" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/97.0.4692.71 Safari/537.36"
rasa_app_1 exited with code 1

@nik202

I think this maybe my problem

app_1              |   File "<frozen importlib._bootstrap>", line 1014, in _gcd_import
app_1              |   File "<frozen importlib._bootstrap>", line 991, in _find_and_load
app_1              |   File "<frozen importlib._bootstrap>", line 975, in _find_and_load_unlocked
app_1              |   File "<frozen importlib._bootstrap>", line 671, in _load_unlocked
app_1              |   File "<frozen importlib._bootstrap_external>", line 848, in exec_module
app_1              |   File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
app_1              |   File "/app/actions/actions.py", line 13, in <module>
app_1              |     import pandas as pd
app_1              | ModuleNotFoundError: No module named 'pandas'

How do I install this module with docker?

@atwine you need to mention this in the requirements.txt file

@nik202

So all I need to do is create a file with requirements and put it in the actions folder or the main rasa folder?

@atwine I guess check how to install requirements.txt file using docker-compose in google. Only putting the files in actions folder will not solve the purpose. The way I used is bit complex as I’m using Github Actions and I have my personal action server image, so I recommend to see the rasa document or take a help from google, as soon as you fix this issue you are good to go.

This is what i did to solve the problem:

# Extend the official Rasa SDK image
FROM rasa/rasa-sdk:2.8.1

# Use subdirectory as working directory
WORKDIR /app

# Copy any additional custom requirements, if necessary (uncomment next line)
COPY actions/requirements-actions.txt ./

# Change back to root user to install dependencies
USER root

# Install extra requirements for actions code, if necessary (uncomment next line)
RUN pip install -r requirements-actions.txt

# Copy actions folder to working directory
COPY ./actions /app/actions

# By best practices, don't run the code with root user
USER 1001

I built it from scratch and then added it to my runtime and then it worked. Thanks

@nik202

@atwine Mean you created the docker file for the sdk. Great and Good Luck!