Rasa x login page "Wrong credentials" error

Hello @rctatman.Can you help.I tried to enter rasa x ui using ip address.But when i just enter it shows me “Wrong credentials” error on the top of login page

Hi @MMustafa, how did you deploy Rasa X? You should be able to see the Rasa X URL in your server logs - it contains a username=<> and password=<> part, both of which are necessary for login.

Hello @ricwo I used these code below 1.curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/0.23.3/install.sh 2.sudo bash ./install.sh But now I have an error “sudo bash ./install.sh”

Is there any reason you’re using version 23.3? If possible, please follow these instructions to get the latest release: One-Line Deploy Script

Sorry let me explain my problem. rasa version==1.9.5 and rasa x==0.27.4.I have created chatbot with rasa and it works fine in terminal but I want to share it with real users so I need to use rasa x.I am using now Juste’s guide The Rasa Masterclass Handbook: Episode 9. So I 1.curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/0.27.4/install.sh 2.sudo bash ./install.sh 3.sudo docker-compose up -d. Then what should I do?Can you explain step by step please

1 Like

You’ll want to set your own password - that’s step 3 here: Docker-Compose Quick Install

I tried to to enter to login page but it also shows error “Wrong credentials”

I did everything step by step as in this guide,but i get an error.Also I tried to run rasa x using “rasa x” command in terminal it does not open rasa x ui in browser shows next in terminal

@ricwo My server use ssh connection.Maybe because of this I can’t open rasa x on browser.How to open it in that case?

Confirm that port 80 is open on the server and that there is not a firewall blocking access.

Thank you @stephens for response and sorry for multiple threads.How to check that firewall not blocking access?

It depends on the system you are using. This is not a Rasa issue.

Hi @MMustafa,

I had the same issue. Error message in logs:

OSError: [Errno 48] error while attempting to bind on address ('', 5002): address already in use

The below solution worked for me.

$ sudo lsof -i:5002
python3.7 44126   hy   54u  IPv4 ****************      0t0  TCP *:rfe (LISTEN)
$ kill -9 44126
$ rasa x