Wrong Credentials after Rasa X Update


I am a newbie and deployed Rasa X (Google Cloud - Docker) as per this tutorial. Everything was fine and I could chat with the deployed assistant until I got a notification about updating Rasa X.

After updating, I kept getting ‘Wrong Credentials’ when typing my login password (see screenshot below). I went through the other topics and tried all (restarting, resetting using sudo python3 rasa_x_commands.py create --update admin me etc.) but no luck. Anyone else with the same problem?


Hey @mayham, what are the two Rasa X versions in question?

Thanks @sams. I didn’t note down the version it told me to install. I tried to find out the current version info but whatever command I looked up didn’t work. What’s the best way to find the version info out?

Have you tried what’s described here? I assume that Rasa X is running (given that you can access the login screen), so you should be able to call the version endpoint…

When I input this: curl https://example.com/api/version

I got the following screen (don’t see any version # )

Ah, right, I see. Well, you have to change the URL to the one where your Rasa X is running :slight_smile: E.g. if your Rasa X starts at http://localhost:5002 like here, then you’d call

curl http://localhost:5002/api/version

Thanks again @SamS :rofl: definitely need some hand-holding with server issues.

The rasa x version is 0.39.0

Hi @mayham , just to note that the tutorial video is a bit older so you may want to double check on the docs instructions Docker Compose Installation that no steps changed.

1 Like

Thanks @mloubser for pointing that out. It may be faster to delete the old instance and go through the installation again (also my gcloud zone changed so I may have to create a new one although Rasa X worked from the new location without changing the zone.)

I’ll report back if that makes a difference.

Tried setting another instance and the python version differences is taking way too long to sync. I spent way too much time on this error and I’ll have to end my rasa x adventure for now. The learning ramp is way too steep and may have to hire a server-side engineer in the future. I hope future iterations of rasa x will be ML engineer friendly :slight_smile:

Update: I just kept going, learning, trying until I got other errors! I went the brute force way and I deleted the Gcloud VM instance and re-did the entire thing and now it’s working. No idea why but I am glad all is well (won’t be doing any rasa updates from now on! It messed up my setting for a reason).

1 Like