NO RaSa Deployments working. ALL methods are deprecated

I am trying to deploy my rasa project to VM on GCP, AZURE from 10 days now. literally even single method isn’t working. both quick installation method or GCP methods aren’t working. couldn’t set admin password though. when the services are going to be get back to working condition ??? any updates??? please suggest even a single VM rasa x installation method which will work as per the rasa documentation.

1 Like

Please give more info on your environment.

Show the outputs of all the following commands:

uname --all
cat /etc/./issue
python -V
pip -V
rasa --version

and any other information you think is relevant

@suhasdevmane I can understand that current rasa X version have new installations methods, but if you having issues with installation please share with us the issues and we will solve them together. Even your feedback regarding installation will help the team to improve the installation and documentation.

@suhasdevmane If you tried all the rasa x new version 1.x installation and if it’s not working, please you can try this version: Docker Compose Installation for Rasa Version 0.42.5 and Rasa Open Source 2.x. I can confirm that on my Ubuntu Server, it’s working fine. On the other hand, if you are trying to install Rasa X 1. X with Rasa Open Source 3.x it will not be able installed as it’s yet not compatible with Rasa 3.X (Ref) : Compatibility Matrix

If you want to try the above mention installation by me, I can help you.

@suhasdevmane Please if you can share your use-case with us that will be great :slight_smile:

Hope this will motivate you and help you. Have a great weekend.

2 Likes

hello nik202. Thanks for informing me. I have started my project with rasa version 42.5 with rasa open source 2.x. now, my rasa x is deployed on VM and working without action server. When i start action server with my actions file, i am not getting utter message on rasa x which is on the actions file. However when i run my rasa shell locally, i am getting utter message with same action file. I couldn’t find what is the actual problem. do i need to use old rasa x SDK for rasax version 42.5 instead of ‘latest’…?

@suhasdevmane Confirm me few things, please.

  • VM is your local machine or Server?
  • Are you able to connect with Github?
  • What method are you using for installation?

@nik202 i have Google Cloud compute VM instance with supported specs. I have connected my project via github repo. i have installed rasa x using docker compose on VM. i think i need to add all off my dependencies for the actions somewhere. no idea how to do that. you can have look at my files at github GitHub - suhasdevmane/RaSa2.0_Smarthome_Demo

@suhasdevmane Well, I am using Github Actions for creating my own private action server image using docker registry, if you like I can guide you on this, else If you have fewer dependencies you manually install the requirement file, or check how you can able to install requirements in docker-compose.

Ref: Using Githubactions for creating own action server image and you can install requirements helpdesk-assistant/continuous-integration.yml at main · RasaHQ/helpdesk-assistant · GitHub

@nik202 lets have a zoom meeting then.

@suhasdevmane I would love to discuss your issue on zoom, please can we fix the time?

thats perfect

@suhasdevmane any update regarding our discussion?

I hope you have followed all the mentioned steps:

  1. Link the VS code with Github, so that you can push the code to Github and it will activate the Github Action Pipeline.
  2. Create the actions_server.yml file in github/workflow which will be run as per new push to main or master branch. Ref: Merge pull request #58 from RasaHQ/fix-model-regression-tests · RasaHQ/[email protected] · GitHub

Tip: Create the secret environment keys in actions in Github with the username and password of the docker hub.

  1. Create a new private repo in Docker Hub for the action_server which will be pushed by Github actions to docker hub.
  2. Update the Image tag in docker-compose.override.yml on the server-side.
  3. Pull the docker image on the server.
  4. Spin the docker-compose on the server.

Tips and Tricks:

To inspect docker container: docker exec -u root -t -i <container ID> /bin/bash

Copy a container from docker to localhost: run the command from the terminal (should be in the project folder)

docker cp <container ID or name>:"/app" "."

Note: Your actions.py code should be the same for the docker container

@suhasdevmane any update?