Web application UI for rasa chatbot


I am very new to chatbots. I have an existing web application where i want to have a chatbot. A very basic chatbot with very less NLP support. More of if else statements then intelligence. Question:

  1. How do i get started
  2. Does Rasa provide UI that i can easily hook into my web page html?
  3. And how to i host it

Thanks, Amit

hey @amitsood welcome to RASA forum, you can get started by visiting this link :

and RASA doesn’t provides an UI to hook into you webpage but yes it do you REST channels where you can integrate your bot

and if you want to do so you visit this link :slight_smile:

Hi @JiteshGaikwad, Thanks for the reply.

So when you say it does not provide a chat UI. Means i have to custom build a chat UI and then use RASA backend as a service to it?

It doesn’t have a channel that hooks into a web app?


yes @amitsood you need to build a custom chat UI and use RASA as backend service,

i have made a custom UI for that, you can get it @


yes it has REST channel that you can use it to hook into your web app

1 Like

Thanks @JiteshGaikwad.

Also do i need to install tensorflow to make this run? And can you copy paste the document whihc you have shown in the video here.

Thanks again

yes, if you want to setup on windows machine i have the tutorial video for that too,

thanks but i have a mac but i can do that

ok @amitsood, i hope you enjoy it :wink:

@JiteshGaikwad, possible for you to share the rsademo text file here. Or just copy all the commands here

hey @amitsood, i am not able to get the rasa demo commands file in my system, but you can get the commands int the video description,

Sure thanks

@JiteshGaikwad, getting following error where i run "

python -m rasa_core.train -d domain.yml -s data/core/ -o models/dialogue/ --epochs 300


usage: train.py [-h] {default,compare,interactive} …

train.py: error: unrecognized arguments: --epochs 300

python -m rasa_core.train -d domain.yml -s stories.md -o models/dialogue try running the above command

actually this code was for previous version

Still get an error. Here it is

might be there’s error in your stories.md file or domain file format

ok, but i haven’t touched any file yet just downloaded it straight as you suggested in the video

ya but that was for previous version :sweat_smile: so now you are facing the issues, better you first start with this one https://rasa.com/docs/get_started_step1/



Does it supports buttons & payload from rasa templates ?