Upgrade Rasa X to the latest version

Hi, I am trying to upgrade rasa x, currently when i do pip show rasa-x, i receive the version as 0.19.0. I understand that there is a newer version. How can one update. i tried pip install -U rasa-x, it did not update

Thanks

hey @souvikg10, you can update using the below command:

pip install -U rasa-x --extra-index-url https://pypi.rasa.com/simple

2 Likes

This method works if you’ve used the basic pip install. If you’ve used the deploy to server method then you cannot upgrade using this method since Rasa X is running in a container.

Is there a recommended method when deployed with the server based ansible/docker install?

can the version in the docker-compose file for the image be changed in that case to pull the latest?

Good idea, looking at the ansible playbook it downloads the compose files and a rasa_x_commands.py file. Of course the ansible playbook may have changed.

There really needs to be a documented upgrade mechanism. I’ll report back what I find.

Here are the upgrade steps I followed to upgrade from Rasa X 0.19.5 to 0.20.0:

sudo docker-compose down
sudo docker pull rasa/rasa:latest
sudo docker pull rasa/rasa-x:stable
sudo docker pull rasa/rasa-x-demo:stable
sudo docker pull rasa/nginx:stable
sudo docker pull rasa/logger:stable
sudo docker pull rasa/rasa-sdk:latest
sudo docker-compose up -d

I compared the following files between the releases and there weren’t significant changes:

curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/stable/install.sh
wget -qO rasa_x_playbook.yml https://storage.googleapis.com/rasa-x-releases/stable/rasa_x_playbook.yml
wget https://storage.googleapis.com/rasa-x-releases/stable/docker-compose.ee.yml
wget https://storage.googleapis.com/rasa-x-releases/stable/docker-compose.ce.yml
wget https://storage.googleapis.com/rasa-x-releases/stable/rasa_x_commands.py
wget https://storage.googleapis.com/rasa-x-releases/stable/scripts/mongo_migration/docker-compose.yml

I’m upgrading another of my Rasa X docker setup and wrote a more complete set of instructions on the upgrade process in this post.

One step missing in my post above is the need to update your .env file with the new Rasa version.