Rasa X won't start - config_path / endpoint problem?

############# Update 2:

Apparently RASA X is not affected when running “pip uninstall rasa” and then re-installing it. Thus, I obtained the latest RASA version alongside my older RASA X version. Using Upgrade Rasa X to the latest version I was able to update my RASA X. Everything is working now.


I have opened the file "“c:\users\ebizlab lenovo 1\appdata\local\programs\python\python37\lib\site-packages\rasa\cli\x.py” which is displayed in the error log and deleted the “, config_path=config_path” part of the local.main(…) function call. Now everything’s working fine again, since local.main doesnt seem to have config_path as a function parameter in my rasa x… it seems like I have gotten an older version of rasa x, 0.22.2, instead of the current 0.24.1 version.


Hey guys,

I have successfully installed Rasa 1.6.1 and created a new bot. The bot was trained and using “rasa shell”, I am able to speak to it via the CLI. No problems using it in the command line.

I ran “rasa x” to check out the bot via the browser interface. Everything loaded just fine, but the conversation tool didnt work: The command interface gave me “couldnt connect to the webhooks” errors. I tried to restart rasa x, but it won’t even start now!

I dont have a screenshot from the “first time” I ran rasa x (when getting the webhook errors), but there was some kind of msg in the CLI, that rasa may have not been correctly shut down? (I used CTRL+C to kill rasa x)

Current outputs:

Showing the log for “rasa x --debug”

I am using WIN10.

Hey @hsrm20! Glad you were able to figure out your problem. Out of curiosity, why are you running Rasa X on your local machine instead of deploying it on a server?