Unable to install Rasa & Rasa -X on windows 10

I am new to RASA as well as to Python, I am trying to setup RASA on my windows 10 machine.

I followed the steps mentioned here Installation Following command always gives me all sorts of error for different packages.

pip install rasa pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

Also tried running, this one also failed

$ pip3 install rasa-x --extra-index-url https://pypi.rasa.com/simple

Unfortunately in the documentation I could not find which version of python & pip to use. I tried with Python 3.8 and 3.5, neither of them worked for me.

pip3 --version pip 19.3.1 from d:\code\code\rasatest2\venv\lib\site-packages\pip (python 3.5)

This is the latest error which I am getting

pip install rasa ERROR: Could not find a version that satisfies the requirement aiohttp~=3.5 (from rasa) (from versions: 0.1,…

I tried upgrading pip, python, but no luck

So far I find it very difficult to setup RASA on my windows machine :frowning:

Can someone helps me giving simple steps to follow to setup RASA.

Atul

Hey @atulsureka, welcome to the community, check this video, I have mentioned in simple steps how to setup rasa on windows 10

https://youtu.be/IAb8Ei7dQjc

Thanks for sharing the video, for you pip install rasa command did the job very smoothly, unfortunately I have tons of issues every time I run it.

BTW which version of Python and pip you used?

Atul Sureka

Python 3.6 and pip 19.0.1

Atul, have you tried installing by cloning the github repo?

This might just work better.

Thanks for your response, I tried setting up RASA using code. I am getting following error with the command

pip install -r requirements.txt

ERROR: Could not find a version that satisfies the requirement rasa-sdk~=1.4.0 (from -r requirements.txt (line 39)) (from versions: 1.0.0rc3, 1.0.0rc4, 1.0.0, 1.1.0, 1.1.1, 1.2.0, 1.3.0a1, 1.3.0, 1.3.1, 1.3.2, 1.3.3) ERROR: No matching distribution found for rasa-sdk~=1.4.0 (from -r requirements.txt (line 39))

BTW I upgraded Python and PIP. I am on 19.2.3 PIP & Python 3.8.

Appreciate any help on this.

A few things, I am not sure how Rasa works with 3.8. I have noticed some problems even with 3.7.3 in certain environment so I am now using 3.6.8. Did you try getting rasa via “pip install rasa.” I am assuming you downloaded the actual repo and are trying to install the packages for it.

BTW I upgraded Python and PIP. I am on 19.2.3 PIP & Python 3.8

Rasa is not set up for 3.8 yet, unfortunately. It supports all versions of 3.6 and 3.7.

Thanks for the response, just tried with Python 3.6 as well, same error. Not sure if RASA actually works with windows 10. I face too many issues in basic installation of RASA program :frowning: