Problem in installing rasa x in windows 10

Hi I have stuck in installing rasa x with the instructions of local mode installation guide. I have tried following commands for rasa x installation:

  1. pip install rasa-x -i https://pypi.rasa.com/simple
  2. pip install rasa-x --extra-index-url https://pypi.rasa.com/simple on applying both the commands, the installation process started but after sometime it got stuck and the message reflected as shown in the following screenshot. I have to abort the process after waiting for long time. Please instruct me how to resolve the issue.

Hello @singhvinay1987

Try this

pip3 install --use-deprecated=legacy-resolver --user rasa-x --extra-index-url https://pypi.rasa.com/simple   

or following command for any specific version of rasa -x

pip3 install --use-deprecated=legacy-resolver --user rasa-x --extra-index-url https://pypi.rasa.com/simple/rasa-x/rasa-x-0.28.3.tar.gz

update the desired version instead of rasa-x-0.28.3.tar.gz

Hi thanks for your response. I tried the commands but an error message is shown below:

the above error is encountered on applying first command. The above error message is shown on applying second command you suggested. Can you please help me out to understand and resolve the issue further. I am using windows 10 operating system and applied the command on anaconda prompt.

Hello @singhvinay1987

Your error is clearly shown in your screenshot.

You need to download and install Microsoft C++ Build Tools.

I will suggest you use a virtual env while installing rasa also.

The problem resolved with downloading MS C++ build tool thanks a lot…

Great @singhvinay1987 .