Rasa X installation takes load of time

I tried to install Rasa X, but it takes lot of time.

I used this command: pip3 install rasa-x --extra-index-url Simple Index Followed the steps provided in the document.

Note: I am using Window 10 and Anaconda environment.

Please help.

@yuvaraj.palanisamy can you share the pip version for the same, or I’d recommend using pip==20.3 and trying to mention the rasa x version

pip install rasa-x==0.42.5 --extra-index-url https://pypi.rasa.com/simple

I’m not aware of this current version, but if you struggle installing the latest version please see this thread for an alternative solution for rasa x installation: Rasa X runs with several Errors & Warnings - #2 by nik202

Can you even share the rasa --version?

Hope this will help you.

@nik202  Thanks for the response,

As per your comment, I have downgraded my pip version to 20.3 and mention the rasa x version as 0.42.5.

But still it takes more than hour to install rasa x. I am not sure how long it will take to install **please help** on this. As of now, I am not getting any error during the installation process.

Earlier I have used below mentioned versions pip & Rasa 
pip version       :         21.2.2
Rasa Version      :         3.0.1
Rasa SDK Version  :         3.0.1
Python Version    :         3.8.0
Operating System  :         Windows-10-10.0.22000-SP0

@yuvaraj.palanisamy What command you are using? its pip3 or pip ?

pip3 install rasa or pip install rasa

@nik202 I am using pip3 pip3 install rasa

@yuvaraj.palanisamy try use pip and get back to me and in above post also see the command.

@nik202 I am getting this message,

INFO: This is taking longer than usual. You might need to provide the dependency resolver with stricter constraints to reduce runtime. If you want to abort this run, you can press Ctrl + C to do so. To improve how pip performs, tell us what happened here: https://pip.pypa.io/surveys/backtracking

After this message installation process take long time (Kind of frozen).


pip install rasa-x==0.42.5 --extra-index-url https://pypi.rasa.com/simple --use-deprecated=legacy-resolver

@nik202  Thanks so much!!! installation completed successfully,  

If I try to launch Rasa X it throws below mentioned error,

**ERROR    asyncio  - Error on reading from the event loop self pipe**
**loop: <ProactorEventLoop running=True closed=False debug=False>**

**OSError: [WinError 995] The I/O operation has been aborted because of either a thread exit or an application request

During handling of the above exception, another exception occurred:**

Please find the Rasa and Rasa X version below:
Rasa Version      :         2.8.15
Minimum Compatible Version: 2.8.9
Rasa SDK Version  :         2.8.3
Rasa X Version    :         0.42.5
Python Version    :         3.8.0
Operating System  :         Windows-10-10.0.22000-SP0

@yuvaraj.palanisamy Great, Please close this thread as a solution as the installation is done.

Try downgrade rasa version to 2.8.11 ? pip install rasa==2.8.11

What is the current error you are facing? and what command you are using? share some screenshot.

I am using command==> Rasa X

Please find the screenshot below,

@yuvaraj.palanisamy confirm me, is you bot open in browser? and you able to talk ?

@nik202 Bot is not opening in browser.

@yuvaraj.palanisamy Right, as expected, I guess version 0.42.5 work fine with Linux but not with Window I guess. You want to try other alternative with different version?

@nik202 Yes, you’re absolutely right. I tried with version 0.39.3 and downgrade rasa version to 2.8.1. It worked for me.

@yuvaraj.palanisamy thanks for the feedback Yuvraj.

Get-pip.py file and store it in the same directory as python is installed. Change the current path of the directory in the command line to the path of the directory where the above file exists.

TalkToWendys Survey