Unable to install rasa on Windows 10

Hi, I am trying to setup rasa. However I seem to have got stuck with the installation itself on Windows 10 Pro. I was following the Getting Started guide.

  • I installed anaconda
  • I opened anaconda powershell
  • Then I ran the following command as suggested

pip install rasa-x --extra-index-url Simple Index

But the installation failed. I would appreciate any help to help me get started. Attaching the installation log.

installation-error.txt (25.7 KB)

hey @newthings4learning, the error is due to Visual C++ build tools, you need to install Visual C++ Build tools, you can get it here:

Visual C++ Build Tools - Visual Studio

Hi @JiteshGaikwad - thanks for your reply. But this link has lots of download links. Can you suggest which ones do I need to download ?

Well some hit and trail worked. At least installation is completed.

thanks !

does that solved your installation error?

Eventually yes. There was another error where it wanted latest 2019.1 version of pytz. somehow my Anaconda distribution had 2018.x. But eventually everything is sorted. Will try to follow the tutorial section now. thanks for your help again.