Couldn't install Rasa on windows 10 P.C

Hey! I am having same error while installing rasa. I tried to do the installation step by step as recommended in RASA Docs but still couldn’t get what was I doing wrong.

First of all, I created a python virtual environment. Then, after activating it I installed ujson and tensorflow in that environment. After that, I used pip install Rasa but it is showing me a long error message each time. I will attach a screenshot of that same error message with this question. Also, I am using python version 3.6 as recommended in some other answers on Rasa’s community page.

I request someone to kindly provide me with a solution so I can be at peace.

I am kinda new to python and Rasa, so if you find something nonsense please bear with me and give me a chance to learn from you.

Thanking you in advance!!


@jdapoorv - You need to install the compiler from Visual Studio - Make sure the Microsoft VC++ Compiler is installed, so python can compile any dependencies. You can get the compiler from Visual Studio. Download the installer and select VC++ Build tools in the list. That should help out

Refer here too

Please do check on these videos of Rachel for a clear step by step process regarding the same

Hey! I have seen both of these but still the problem remains. I’ve installed Visual studio c++ 14 version and now it is showing a completel new error. In these videos it just downloads peacefully after installing tensorflow but in my case it does not. It is showing me some error as below :

      Building wheel for ujson (PEP 517) ... error
  ERROR: Command errored out with exit status 1:
   command: 'C:\Users\Lenovo\.conda\envs\env2\python.exe' 'C:\Users\Lenovo\.conda\envs\env2\lib\site-packages\pip\_vendor\pep517\' build_wheel 'C:\Users\Lenovo\AppData\Local\Temp\tmpogffct0b'
       cwd: C:\Users\Lenovo\AppData\Local\Temp\pip-install-f5lmobk0\ujson
  Complete output (16 lines):
  running bdist_wheel
  running build
  running build_ext
  building 'ujson' extension
  creating build
  creating build\
  creating build\\Release
  creating build\\Release\deps
  creating build\\Release\deps\double-conversion
  creating build\\Release\deps\double-conversion\double-conversion
  creating build\\Release\lib
  creating build\\Release\python
  C:\Program Files (x86)\Microsoft Visual Studio\2019\BuildTools\VC\Tools\MSVC\14.27.29110\bin\HostX86\x64\cl.exe /c /nologo /Ox /W3 /GL /DNDEBUG /MD -I./python -I./lib -I./deps/double-conversion/double-conversion -IC:\Users\Lenovo\.conda\envs\env2\include -IC:\Users\Lenovo\.conda\envs\env2\include -IC:\Program Files (x86)\Microsoft Visual Studio\2019\BuildTools\VC\Tools\MSVC\14.27.29110\include /EHsc /Tp./deps/double-conversion/double-conversion\ /Fobuild\\Release\./deps/double-conversion/double-conversion\bignum-dtoa.obj -D_GNU_SOURCE
  ./deps/double-conversion/double-conversion\ fatal error C1083: Cannot open include file: 'math.h': No such file or directory
  error: command 'C:\\Program Files (x86)\\Microsoft Visual Studio\\2019\\BuildTools\\VC\\Tools\\MSVC\\14.27.29110\\bin\\HostX86\\x64\\cl.exe' failed with exit code 2
  ERROR: Failed building wheel for ujson
Failed to build ujson
ERROR: Could not build wheels for ujson which use PEP 517 and cannot be installed directly

I’d be releived if you could find me a way out of this labyrinth. Its been two days that I am trying to install Rasa and every time I am unsuccessful. I am newbie pls help me out.

@jdapoorv - Are you doing it in a virtual env set up ? Check on here this issue seems to have been resolved here - Could not build wheels for ujson which use PEP 517 and cannot be installed directly · Issue #337 · creativecommons/cccatalog · GitHub

Try uninstalling the current version of ujson conda unistall ujson


Try installing the ujson - 1.35 conda install ujson==1.35

To install Rasa on Windows 10, you will need to have Python and pip (the Python package manager) installed on your system. If you do not already have these tools, you can download and install them from the official Python website or by following these instructions:

  1. Open a command prompt window and run the following command to check if Python is already installed: python --versionIf Python is installed, you will see the version number displayed. If Python is not installed, you will need to install it by following the instructions on the Python website or by using a package manager like Anaconda.
  2. Once Python is installed, you can use pip to install Rasa. Run the following command to install Rasa: pip install rasaThis will install the latest version of Rasa and its dependencies.
  3. Once the installation is complete, you can verify that Rasa is working by running the following command: rasa --version this should display the version number of Rasa that you have installed.
  4. To start using Rasa, you can create a new project by running the following command: rasa initThis will create a new directory with the necessary files and directories for a Rasa project. You can then use the Rasa command line interface (CLI) to train and run your Rasa bot.