Testing Rasa Bot with Botium

Hey everyone, So here’s my next tutorial video on testing chatbots. So in this video, I have shown how you can test your Rasa chatbots using Botium Box.

hope this helps :slight_smile: Thanks


awesome tutorial, thanks for this

1 Like

you’re welcome :slight_smile:

this didn’t work for me :confused: I followed your steps and I have an error, tested my ngok link with curl it works perfectly can you help me identify the problem please @JiteshGaikwad ?

Thanks in advance :slight_smile:

@AminaDerouiche What is your error can you share some screenshot and after which step your error occurred?

@nik202 , I didn’t do anything complicated, Here are the steps I followed:

  1. created the account on botium box
  2. run rasa run --port 5055
  3. run ngrok http 5055 (same port)
  4. putting the ngrok URL in the HTTP(S) endpoint URL of your Rasa chatbot host , like the picture shows I couldn’t connect , it takes a while keep uploading but finishes by an error ,

I used the ngrok URL with curl and every thing works well

Thanks for your answer, I hope you can help :slight_smile:

@AminaDerouiche Is your rasa server is running on 5055 and your actions server ???

@nik202 I don’t have custom actions so I only need to do a rasa run

@AminaDerouiche is your rasa server is running on 5055 or 5005 (which is default port for rasa open source) ???

the default one is 5005

@AminaDerouiche when you run rasa shell --debug or rasa run -m models --enable-api --cors "*" --debug what is your http? or you specifically running the rasa server on port 5055?

forget about the 5055 my bad. I tried with 5005 and didn’t work

here is exactly what I have done

@nik202 did you try to use it ? did it work ? I followed this tutoriel and unfortunately it didn’t help

[solution] @AminaDerouiche

Try use this command on terminal for running rasa server and then ngrok ( hope you activate the ngrok authentication)

rasa run -m models --enable-api --cors "*" --debug

it’s okay, I will try to have look tomorrow and will keep you posted Thank you so much for your help

@nik202 it worked with your command !!! Thank you so much :smiley:

@AminaDerouiche No worries and good luck! Next time please create a issue thread for your solution reference and good luck!

1 Like