Spacy v3.0 model/pipeline error

I tried installing Rasa but seems Spacy is now at v3 and a lot has changed. Trying to complete rasa installation by doing python3 -m spacy link en_core_web_md en returns error that link is depreciated.

How can I go about linking models/pipelines in spacy v3 ?

Write language: en_core_web instead of language: en in your config.yml

Thanks, I changed language:en to language: en_core_web_trf to my config.yml because I used python -m spacy download en_core_web_trf .

But how do I link it? Rasa docs says to run python3 -m spacy link en_core_web_md en but I get error: Error: Missing argument 'KWARGS'. when I run python -m spacy link en_core_web_trf

If you’re using Spacy version 3.x, you don’t need to link it, you just change it in you config.

The docs assume you have Spacy 2.x.

running pip list shows spacy is installed but when I run rasa train, i get:

`MissingDependencyException: Not all required importable packages are installed to use the configured NLU pipeline. To use this pipeline, you need to install the missing modules: `

- spacy (needed for SpacyNLP)

Please install the packages that contain the missing modules.

Please what am I doing wrong?

Huh this is weird.

Try pip install rasa[spacy]. This will get you back to Spacy 2.x I think, and you’ll have to download Spacy 3.x again.

Or, if you have no problem, just stay with 2.x, but you’ll have to link.

Thank you for the help.

I followed the instruction and python -m spacy link en_core_web_md en returned ✔ Linking successful.

Running rasa train still shows the same MissingDependencyException error for spacy. Doing pip list shows spacy at 2.2.4

Is it safe to remove this line: name: SpacyNLP model: "en_core_web_md" from my config?

Weird for the error… sorry, I don’t know how to help with that.

As for name: SpacyNLP model: "en_core_web_md", yes you can remove it. Just mentioning language: en before the pipeline (first line of config.yml) is enough.

Thank you for your time. Really appreciate. I had to do rasa init and copy over the files.

1 Like