Spacy linking deprecation error

When I using the command “python -m spacy link en_core_web_md en”. I receive a deprecation error. So, I can’t link spacy

Rasa Version: 2.3.4

Rasa SDK Version: 2.3.1

Rasa X Version : 0.37.0

spaCy version 3.0.3

Platform Windows-10-10.0.18362-SP0

Python version 3.7.6

Pipelines en_core_web_md (3.0.0), en_core_web_sm (3.0.0)

link is deprecated as of SpaCy 3.

As the last line says, just write language: en_core_web_md directly in your config instead of en.

1 Like

It’s the same error

1 Like

This is caused by model: external_data/spacy.word2vec.model in your pipeline. Same error, but not same cause.

Do you need that model? If you remove it it will probably work.

By the way, you have a typo in your pipeline under DIET, you wrote epoches instead of epochs.

1 Like

It’s working now. Thank you…

1 Like

Great! You’re welcome!

1 Like

I am very interested in using spacy version 3.

If anyone has found a way to use it, please let me know.

My workaroud to use spacy the old way is as follows:

  • pip uninstall spacy
  • pip install spacy==2.3.5
  • python -m spacy download en_core_web_md

(for Windows 10, it is important to open the terminal as administrator at the next step)

  • python -m spacy link en_core_web_md en

I hope this helps.

1 Like

Hello @Johan1us.

I installed SpaCy 3 and en_core_web 3 as you did in your reply:

pip install --upgrade spacy
python -m spacy download en_core_web_md

(In my case I downloaded the model via pip with the GitHub URL to be able to use the --default-timeout flag since my connection is really slow)

But don’t use link. You just need to write language: en_core_web_md in your config.yml instead of language: en.

3 Likes

@ChrisRahme

Fantastic! Now that you mention it. I overlooked your previous post.

Thanks a lot! :+1:

3 Likes

Thankssssssss!!! :star_struck:

2 Likes