Spacy Model Linkage Error when launching Rasa X

Hello and thanks in advance to anyone who can help. When launching rasa x I get the following error on Mac OS X:

rasa.core.agent  - Could not load model due to Model 'en_core_web_md' is not a linked spaCy model.  Please download and/or link a spaCy model, e.g. by running:
python -m spacy download en_core_web_md
python -m spacy link en_core_web_md en.

Due to network restrictions, I have downloaded the model as a tarball and linked it as follows: python -m spacy link ../SPACY_en_Models/en_core_web_md-2.1.0.tar.gz en

This appears to have worked, based on the following output:

Linking successful
../SPACY_en_Models/en_core_web_md-2.1.0.tar.gz -->
/Users/username/anaconda3/lib/python3.7/site-packages/spacy/data/en

You can now load the model via spacy.load('en')

However, it still results in the original error.

Thanks so much.

Hm, what does your config look like? It may be that you actually need to link it to the en_core_web_md name

Thanks Akela, that’s a good idea. Unfortunately, linking to “en_core_web_md” produced the same error. I’ve submitted a bug report on this as well: Spacy Model Linkage Error when launching Rasa X · Issue #4650 · RasaHQ/rasa · GitHub which has more information.

1 Like