OSError: [E050] Can't find model 'en'

I have this problem when I run make cmdline OSError: [E050] Can’t find model ‘en’. It doesn’t seem to be a shortcut link, a Python package or a valid path to a data directory.

I have spacy v2.1.3 and en-core-web-sm and en-core-web-md 2.1.0 which are compatible

install spacy and then run following: python -m spacy download en

after installing spacy with command python -m spacy download en, u need to link the spacy model with the following commands ;

import spacy


Thank you for the answers. But it doesn’t make the link because it says “You do not have the privelage to do this”…

Do the loading and linking of the spacy model in admin mode of your command prompt.

1 Like

Thank you very much! That worked!

I have the same issue, and I am running Jupyter Lab from a server. When I try this command - python -m spacy download en, it says no module found

which os is the server? check spacy installation on that. You’ll get plenty docs on that. Or let me know the version.

Hi Akshit, this is the server details: Linux 43fa2ec0c81a 4.15.0-47-generic #50-Ubuntu SMP Wed Mar 13 10:44:52 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

I am trying to find a way to use "python -m " commands. Thanks for your quick response

So as your error says “No module found” that’s spacy correct? You have successfully setup the environment for python right?

Yes, when I try this in my terminal - “python -m spacy download en” I get the following error message /usr/bin/python: No module named spacy

But inside Jupyter, when I import spacy, it works fine.

Well You tried these right?

pip install rasa_nlu[spacy]

python -m spacy download en_core_web_sm

python -m spacy link en_core_web_sm en

was the linking successful?

That is not successful either. image

Had to use Python 3!!! I think it should solve the issue. Will keep posted