MissingDependencyException spacy

I have the following pipeline in my config.yml:

language: nl

Option 1 spacy pipeline


  • name: SpacyNLP model: “nl_core_news_md” case_sensitive: False
  • name: SpacyTokenizer
  • name: SpacyFeaturizer
  • name: RegexFeaturizer
  • name: LexicalSyntacticFeaturizer
  • name: CountVectorsFeaturizer
  • name: CountVectorsFeaturizer analyzer: “char_wb” min_ngram: 1 max_ngram: 4
  • name: DIETClassifier epochs: 100
  • name: EntitySynonymMapper
  • name: ResponseSelector epochs: 100

When I give the rasa train command, I get the following error message:

(venv) D:<pathtoapp>>rasa train The configuration for policies was chosen automatically. It was written into the config file at ‘config.yml’. 2021-03-05 14:36:45 INFO rasa.model - Data (stories) for Core model section changed. 2021-03-05 14:36:45 INFO rasa.model - Data (nlu-config) for NLU model section changed. Training NLU model… MissingDependencyException: Not all required importable packages are installed to use the configured NLU pipeline. To use this pipeline, you need to install the missing modules:

  • spacy (needed for SpacyNLP) Please install the packages that contain the missing modules.

However spacy has already been installed in the venv using pip install spacy.

What could be wrong?

Could you try:

pip install rasa[spacy]

Also, could you run:

rasa --version

I have run pip install rasa[spacy]. I run rasa version which resulted in: D:\VirtualAgent\pythoncomponents\voicebot4>rasa --version Rasa Version : 2.1.1 Rasa SDK Version : 2.1.2 Rasa X Version : None Python Version : 3.7.9 Operating System : Windows-10-10.0.19041-SP0 Python Path : c:\users\roelb\python37\python.exe

I run rasa train again and this gives the same result

In the mean time I have upgraded rasa to version 2.4.0 and performed a new rasa train with the spacy pipeline. The aforementioned error has now disappeared. So the issue seems resolved.