Something went wrong. Please try again (rasa x)

Version: Rasa X 0.35.0

Hi, I am using Rasa x 0.35.0 on my server and i try to connect to my github repo but rasa x tell me the “Something went wrong. Please try again.” I am using rasa open source 2.2.9 and rasa sdk 2.2.0. Please i need your help. I am new to rasa.

Hey @Papa,

Where does this error appear? It sounds like it appears in the UI, is that correct? If so, could you provide a screenshot and some more details or where the error appears and exactly when it appears and I will try to help.


Hey @mjaycub Yes it appear in the UI when i attempt to connect to my gitlab repo.

Hi!, Have you solved it? Thanks

Yes. Are you using gitlab or github ?

I´m using GitHub

You have to check if your server can communicate with github. Are you using your own server or not ?

How can I check it ?.

I have connected my git repository, two days ago but then I disconnected because I thought I was doing something wrong.

When I tried again to connect it the problem started.

I´m using a server that I have created with Compute Engine (GCP)

What changes did you make?

The first time I connected my repo Rasa X doesn´t recognize stories, so I searched at the internet and have found that you have to upload all the files like domain.yml, stories.yml … before connection.

This is my repository: GitHub - mariasanzs/rasa-bot: Chatbot en para complementar terapias antiestrés en mujeres embarazadas con RASA.

try to restart you rasa x (You can use docker-compose restart if you 've used docker-compose installation).

I have restarted rasa x but it is still doing the same

update your rasa x. You can follow this link Update Rasa X

I alredy have updated the rasa x server RASA_X_VERSION=0.40.1

This is not the problem

have you restartet your server ?


Hi both,

I have the same error message after following Rachel’s instructions on Youtube on how to connect RasaX to a github repo. I am also using a virtual machine, but I am a newbie to this and don’t yet know how to investigate why something has not worked. Maybe a silly question, but at the moment, the only thing I have on my VM is RasaX, i.e. not Git. Does Git need to be installed as well?


Sorry, Git is installed so that is not the issue either.

How do I pin down what is wrong? I’m not clear on which logs to pull out or how to do it.


Hi @LornaJ which installation mode are you using? if your are using docker-compose you can use docker-compose logs rasa-x to view you rasa x logs

Hi @Papa , I did that yesterday, in parallel to hitting Verify connection and all I got was the same repeated message both before I hit Verify, when I hit Verify and afterwards. See screen dump below.


I’m guessing this is not diagnostic?