Connecting Github Repository with Rasa X 1.1.0 doesn't show correct files


I connected my Rasa X 1.1.0 deployment (GCP VM with Kubernetes Cluster, Rasa 3.1.0 ist also deployed) with my GitHub repository containing the files for a Rasa 3.1.0 bot. The connection itself seemed to succeed since no errors are thrown and the domain file is displayed correctly.

However, it is only the domain file that is displayed. Instead of the correct configuration file I only see the default pipeline in the Rasa X GUI and all the other files (stories, intents, rules, synonyms etc.) are completely missing. Rasa X tells me the connection is up to date (green) and whenever I push the changes in Rasa X to GitHub, the correct commit including the message is created and displayed in GitHub, but no files were added or edited, no matter what change I applied in Rasa X.

I tested the same bot with my Rasa 3.1.0 local installation and it worked flawlessly.

Changing the connected branch oder reconnecting the repo with new deployment keys didn’t solve my issue.

Maybe somebody of you can tell me what is wrong with my connection from Rasa X to GitHub?

I have the same problem. I ended up rolling back to 3.0.9 and it works.

It seems like the compatibility matrix is incorrect?

Unfortunately, this didn’t do the trick for me. I downgraded the Rasa installation in my deployment to 3.0.9 and changed the version-tags in my files to 3.0 as well. I also reconnected the repository by using a new deployment key. But the observations are still the same as explained in the first posting.

Thank god I am not alone. Also on Rasa X 1.1.0 and Rasa 3.1.0.

My experience was similar in that most of it in the GUI was empty, however the config file was displayed and loaded correctly.

What fixed it for me was changing version 3.1 in all files to 3.0 (also they technically are not). Then everything was loaded correctly in the GUI. I have no idea why.

1 Like

Can you confirm that the config.yml was displayed correctly? In my case only a default config is shown (I noticed it because I did some minor changes on the pipeline which were present in my github’s config, but not in the one Rasa X showed me).

And did you do anything else after changing the version tag to 3.0 in your files? I thought I did the same, but I haven’t solved my issue. Maybe I’m missing on something.

I had the same issue and downgrading the version tag in the files to 3.0 instead of 3.1 did the trick. Is there any error displayed using rasactl logs maybe in the rasa x container?