Something went wrong. Please try again

Version: Rasa X 0.28.0

When trying to connect the rasaX service to a git repo it shows the error message “Something went wrong. Please try again.” Nothing else.

f12 shows “Failed to load resource: api/projects/default/git_repositories/:1 the server responded with a status of 422 (Unprocessable Entity)”

Hi @jsolis, Can you describe in more detail the steps you are taking to connect to the git repo?

Is it github or another git host?

I just followed the steps on the documentation.

  1. Give it the ssh URL
  2. Give it the target branch
  3. Add the deploy key to the repo in gitlab

After that, when I click on Verify connection it shows the error described. It is rasaX 0.28.0 deployed using the single line deploy script mentioned in the documentation. Deployed inside ubuntu 20.04

EDIT It is important to mention, this is not our final deployment. We are merely testing what works and what doesn’t.

I forgot to mention it is a hosted gitlab

@Arjaan We tried doing it in a docker_compose install and we are getting this from the request:

{

"version":"0.28.2",

"status":"failure",

"message":"Insufficient permissions for remote repository.",

"reason":"RepositoryCreationFailed",

"details":"Given repository credentials don't provide write permissions to the repository. Please make sure the ssh key is correct and the administrator of the remote repository gave you the required permissions.",

"help":null,

"code":422
}

The ssh key is not password encrypted and the permissions are setup correctly. The repositories.json file looks like this:

{

    "repository_url": "git@git..........................",

    "target_branch": "master",

    "ssh_key": "key without newlines"

}

Please advice, help is appreciated.

I also got the same problem as " [Something went wrong. Please try again] when trying to add a git repository and expend 4-7 hours for this.

But unexpectedly, I solved this problem in a weird way. My repository had two branches name [main] and [master]. The [main] branch was the default branch of GitHub and I have switched the default branch to the [master] branch.

There was nothing in [main] branch, therefor delete this branch and connect again repository using Rasa-x documentation.

  1. Add it the ssh URL
  2. Add it the target branch
  3. Add the deploy key to the repo in GitHub

Wow. :slight_smile: ) solved my problem

Thanks, Maksud