Can't connect to bitbucket

Hi, I’m successfully installed rasa x in my server. I tried integrate version control with github and its working but not with bitbucket. My company used bitbucket as git repo of all our code.

The error that I received is “Something went wrong. Please try again”. Need guidance on how properly connect rasa x with bitbucket

Hey @fromhell13 can you outline the steps you took? And where did you see this error?

Hi @akelad, thank you for your response.

I’m following this step Integrated Version Control. I saw the error when i tried to connect my Rasa X to bitbucket. I tried both public and private settings, the error still appear

Can you show me the Rasa X logs from when you try to connect? There will probably be an error in there

Hi, I got the same error. When i try to connect to github, it works. @akelad Where can i see the Rasa X log?

@SK-KyubeomKim welcome to the community :slight_smile: How did you deploy Rasa X? If it’s with docker-compose, then sudo docker-compose logs rasa-x. If it was with the one line deployment script or kubernetes, then you can read the instructions here.

I am getting the same error trying to link my Bitbucket repo. I am using docker-compose and the error I extracted from the log indicates that credentials with repository write permissions are required: repository credentials don’t provide write permissions to the repository. Please make sure the ssh key is correct and the administrator of the remote repository gave you the required permissions.

Unfortunately, the Rasa X docs only suggest to use an Access key, but Bitbucket Access keys provide just read-only access.

Not sure how this can be solved with Rasa X since it seems that only users with associated emails can have also write access.

Hi @Roebius, I’m not super familiar with bitbucket myself, but I’ve asked someone else on our team for some input.

1 Like

Thanks! In the meantime, as a workaround I have moved my repo to GitHub.

Bitbucket doesn’t allow to set the write permissions on a per repo basis like GitHub does. You have to give write permissions to ALL the repositories under your account. If you want to go that route go to your account ssh keys and add the key that Rasa X gives you.

1 Like

Thanks @flythe, just had that confirmed from my team as well. So I don’t think there’s much we can do about this, seems like the only option is to give the account write access to all repositories.

1 Like


Lots of people facing the same issue while integrating with bitbucket. you can see log error here: you can do docker-compose logs or to get specific logs for a service docker-compose logs <name of the service> (e.g. rasa-x , rasa-production )

Thanks & Regards, Anita

Bitbucket Access Keys are read only - Rasa X seems to require read/write.

My fix was to switch this repo to github.


I use Bitbucket with Rasa X on OCP (Openshift). I can read/write via SSh-key No problem at all.

I didn’t install it my self, but a specialised OPS-colleaque. It seemed he had quite a hard job. Appearantly not because of Rasa, but merely because off my companies security and deployment policies.

I’m satisfied with this Rasa X OCP installation. Although I meet some annoying issues, those can also be found on the forum: