Responses not showing up, but model working in interactive mode RasaX: 0.33

Hello! I am setting up the new Rasa X with my recently migrated Rasa 2.0 assistant.

When I try and chat with the assistant on the interactive page I just get ‘…’. This is the same in Safari, and when I try chatting as a guest user.

When I put it into interactive mode the next actions are being accurately predicted, (like ‘utter_greet’) but again not showing up in the actual chat. Still just ‘…’.

Does anyone else have a similar issue? I think it might have to do with the database connection since when I say ‘hello’ in the chat it does not show up in the conversation history.

I am quite new at this so any help would be much appreciated :slight_smile:

1 Like

Same is happening to me with Rasa 2.0.2 and Rasa X 0.33.0, using the manual docker-compose setup. Help would be greatly appreciated.

Hey @armanjindal @zfunction

It’s a known issue, we’re working on a fix! Stay tuned!

3 Likes

Hi @degiz, thank you. Do you have an ETA?

I’m having the same problem in a helm chart deployment.

Hello Marissa,

That is odd. Because when I re-deployed using a Kubernetes cluster for GKE with a Helm Chart, the issue disappeared. It’s not an elegant fix, but honestly just re-deploying it might do the trick! :slight_smile:

We reverted to 2.0.2-full (from 2.0.3) and that seems to have resolved the issue.

Hi,

I’m still having the same issue with my docker-based deployment using following versions:

RASA_X_VERSION=0.33.0
RASA_VERSION=2.0.2

Hi,

I’ve tried with rasa x 0.33.1 and rasa 2.0.2/3 and I have always the same issue. It would be helpful if someone can give us some informations about ETA.

B.R

I’m having many of the same issues. I am using the following:

Rasa: 2.0.2 Rasa X: 0.33.2 Docker-Compose installation using the install.sh script on a google cloud platform VM (followed the example in Rasa Masterclass for the most part).

I had Rasa X working (mostly) with my previous Rasa 1.X models, but I migrated to Rasa 2.0 to use some of the new features. I wanted to share my bot with a few other individuals via Rasa X but I am unable to have conversations (though the correct responses are predicted in interactive mode and not showing).

Additionally, I was having issues pushing changes to my linked github repo. None of the conversations I attempt to have via the “share your bot” interface or the “talk to your bot” tab are even showing up in the conversations tab at the moment. My model does seem to function successfully if I run rasa shell or rasa interactive in the command line locally.

Has anyone found a workaround for this?

Hi, No workaround for me, I will wait the next version of RASA X to see if it fixes the issue.

Hi,

I could finally solve this issue. I’m deploying my bot using docker-compose, so for migrating it to Rasa 2.x I had to backup/delete the following files in the /etc/rasa directory before running the RasaX install.sh script:

  • credentials.yml <== backup if you have setup other channel i.e socketio
  • endpoints.yml <== delete. probably this is the most important
  • environments.yml <== delete. probably this is the most important
  • rasa_x_commands.py <== delete
1 Like