Rasa X Server install help- 'please fill all the fields'

I followed the server installations, running on DigitalOcean, met min requirements, installed my IP address shows Rasa, but…

  1. when I get to step 4 admin password -

sudo python rasa_x_commands.py set_password PASSWORD

I get an error, invalid choice: ‘set_password’ (choose from u’create’ u’delete) So I was able to create an admin username password with -

sudo python rasa_x_commands.py create admin USERNAME PASSWORD

It worked, it creates a user, but since this is a free and not enterprise I don’t think I have a username.

tl;dr But the big issue, my IP address shows the login screen with Welcome, password sign in or I have enterprise ID, and no matter what I do I get Please full all the fields in red above, can’t click buttons or do anything, I tried Chrome and Firefox, same issue

@FelixKing can you post an issue on github please?

I don’t see anywhere to post the issue? I see the Rasa Git, but I don’t see the proper place to post an issue for the Rasa X server install?

You can post here: Issues · RasaHQ/rasa · GitHub

@FelixKing would be great to get some feedback on your experience with Rasa X so far: Product Feedback - Rasa X

i am having one doubt, please help me, its urgent

how r u i am not able to get something working with rasa if i have to ask bot with some question, it reply me with " what about coffee…? "

  1. yes 2. no 3 . notyet

1.and if i type yes i will get answer for yes 2.if i type no, i will get answer for no 3.if i type notyet, will get answer for that

answer me please, i am using rasa x latest version please answer me with

domain.yml and stories.md file also, please… need urgent

no one helping me here…no reply at all…its really unfair guys

LOL. Stop spamming the forum, please.

1 Like

i posted question yesterday, but no one reply me …its really painful…ok

hey @jkohl …u can reply me if u know please…i am waiting for the answer

  1. you have asked your question in several existing threads, unfortunately this is spam
  2. your question had nothing to do with these existing threads
  3. you obviously didn’t buy support / SLA. Then you are not entitled to an answer to your question, let alone within 24 hours.
  4. referring multiple times to the urgency does not help in an asynchronous communication medium.
  5. your question is completely incomprehensible and confusing to me. I have difficulties to guess what could be meant at all.
  6. unfair in relation to what? Someone from the internet makes arbitrary claims that are not met - that’s not the definition of unfair.

Suggestion: Stick to the thread you’ve already opend. Try to reformulate your question so that one can understand it without difficulty and then practice patience.


For Rasa X CE you have to update the default user because you don’t have multiple user names. Default user name is me

Here’s how you update the default user password:

sudo python rasa_x_commands.py create --update admin me <password>

1 Like

Thanks Gabriel.

It worked. :muscle: