Getting error when set admin password with this command for rasa-x

hey, I am getting the following error, when set the admin password for rasa x.

sudo python create --update admin me admin

Syntax error:

File "", line 102
    command = f"delete {args.username}"
SyntaxError: invalid syntax

I have the same problem. Any solutions?

I just replaced f"delete {args.username}" with “delete {args.username}” and it worked

@louiswillems. thanks for the answer.

I deployed rasa x into the production server. So, where will replace the code.

I went to my default folder like:

cd /etc/rasa/

Execute following command:

docker-compose exec rasa-x bash -c “python3 /app/scripts/ create me welcome123 admin --update”’

Added --update at the end because it gave me the below error message without --update :

User ‘me’ already exists. You can update the password by running sudo python create --update me admin <new_pw>

1 Like


solved my problem… please check the solution :slight_smile:

I get this error : ERROR: Couldn’t connect to Docker daemon at http+docker://localhost - is it running?