Rasa x installing but taking too much time

I am trying to install RASA-X but pip installation is getting too much time. but if I try to install any other lib its working fine. I am using pip3 install rasa-x --extra-index-url https://pypi.rasa.com/simple to install rasa-x

rasa version: rasa 2.3.0 rasa-sdk 2.3.1

I tried with rasa version 2.1.0 and 2.2 also same issue

can any one help me to solve this issue

Hi.

I had the same problem. The solution in this post was helpful: Rasa X install stucked

I hope it will help you too.

@Imhotep thanks it’s solved my issue but I am not able to run the rasa-x.

have u faced this issue? can u plz suggest me the solution?

did you started rasa x in the folder, where you have your rasa project? And do you have the required files there?

For example …\Desktop\Chatbot → you need to change to this folder in your command prompt.

And in this folder you need the files, thats required, like stories, nlu, etc. If this is missing, try to type rasa init in your command prompt.

I am running inside the rasa project. I think some issue with the version. I am using rasa 2.3.0 rasa-sdk 2.3.1 rasa-x 0.35.1

Seems like your data is not valid.

Did you try running rasa init first in your project’s directory?

Does rasa shell work?

Also, try running rasa data validate.

@ChrisRahme rasa shell, interactive all working fine. Only rasa x is not working :pensive:

1 Like