Endless install time for Rasa X

Why is Rasa X taking a million years to install? It starts well, then stuck on “INFO: pip is looking at multiple versions of h2 to determine which version is compatible with other requirements. This could take a while.”…After 5 years, it continues, then stuck again. Now it’s waiting the rest of the years without finishing.

I honestly doubt it’s my internet. What is the fix, please?

It’s a problem with the new version of Pip.

Add --use-deprecated=legacy-resolver to the command.

Full command:

pip install rasa rasa-x -i https://pypi.rasa.com/simple --default-timeout=10000 --use-deprecated=legacy-resolver
1 Like

maybe this will help, downgrade to pip-20.2,you can try.

i have successfully installed rasa x as per your command but i can’t open rasa x, error like below, help me plz

Is there any error on the command line?

HERE, help me plz !!!

I used this command and it has worked for me.

pip3 install --use-deprecated=legacy-resolver rasa-x --extra-index-url https://pypi.rasa.com/simple

then I spin up rasa using rasa x

Try and see if it works now


The suggestion from @laboratory worked for me - thanks Charles!

I did get this output, below, at the end, but it did not appear to cause me problems and this method was light years ahead of trying with the standard resolver in pip 21.0.1 (I had thought I’d give it a go but it was taking more an more time so I eventually gave up)

ERROR: pip’s legacy dependency resolver does not consider dependency conflicts when selecting packages. This behaviour is the source of the following dependency conflicts.

sanic-jwt 1.6.0 requires pyjwt==2.0.0, but you’ll have pyjwt 2.0.1 which is incompatible.

Successfully installed GitPython-3.1.14 Mako-1.1.4 MarkupSafe-1.1.1 alembic-1.4.3 attrs-19.3.0 croniter-1.0.10 gitdb-4.0.7 isodate-0.6.0 kafka-python-1.4.7 pika-1.2.0 python-editor-1.0.4 rasa-x-0.38.1 sanic-jwt-1.6.0 smmap-4.0.0 ujson-1.35

Might be worth a few people submitting their details via PyPI’s survey, as detailed in the pip output:

To improve how pip performs, tell us what happened here: https://pip.pypa.io/surveys/backtracking

I did it with my details but others confirming their similar details will underline that it’s not a one-off / user error, so PyPI can consider it. Of course there may be some narrowing down of the version requirements that could be done on the Rasa side too (I’m not 100% sure on this)

Sorry, I should also credit @ChrisRahme too as it was originally his comment on the resolver (although I used it as per Charles’ comment and didn’t need the default timeout part)

1 Like


Yeah I added default-timeout cause why not :joy: Internet is so bad here that it kept timing out during Rasa’s installation.


I have the same problem, managed to find any solution?

The solution is right here in the thread. Let me know if you cannot find it. At this point, I am careful to mark which is the actual solution. @ChrisRahme deserves some credit because he suggested the solution. I simply came up with a solution building on his suggestion.

Straight to the point, this worked.

pip3 install --use-deprecated=legacy-resolver rasa-x --extra-index-url https://pypi.rasa.com/simple"

please let me know if otherwise

1 Like