Rasa run actions is stuck

When I am running rasa run actions, it is not showing me the port. I checked with --debug and it is showing the attached message. I don’t know what that means. Can you please help me… When I am running a rasa shell and typing hi, I am getting an error saying that the mentioned message is not present in the domain.

Hello @sinhasangram ,

Welcome to our community! :clinking_glasses:

The default port for the action server is 5055, you can check if it’s open using the command netstat -anb.

About your shell test, you need to be sure that all of your intents are listed into domain.yml file before doing the train, and that you’re running RASA from the same directory where exist a folder models or pointing it to the correct location of the model file location (param --model).

I recommend you read this two links below.


1 Like

Thanks, i will look into it. The port 5055 was in state listening when i ran rasa run actions and it went away when i closed it. So, i am pretty much sure it is using that port but not sure why it is not reflecting while running rasa run actions And my intent is listed in my domain.yml file. I am running from the same directory where RASA and folder models is. But, I checked my model using rasa interactive and it was working perfectly fine… no errors, my model is able to classify correctly the intent and the entity mentioned here and giving me correct output.

Depending on how you run your action server, it’s possible it’ll continue to run in the background.

If you’re certain you don’t have anything “official” using that port, and it is indeed the Rasa Action Server, you can kill the process

If you’re on Windows (I’m on 10 so the interface may vary if you’re not), run the Task Manager, go to the Details tab, and look for rasa.exe, select it and click End Task .

If you’re on Mac / Linux you can open a terminal and kill the process running on port 5055 like this:

sudo lsof -t -i:5055

Of course you can always reboot to clear out the processes too haha. Good luck.

@lluchini can you please help me with a similaire issue i have, i want to test my chatbot, when i try to run: rasa run actions , all the actions get registered and once finished, the all process ends, it does not keep running … how am i supposed to deal with that ? my goal is to test using rasa shell, and when i run that cmd, it gaves me that error : Failed to run custom action ‘action_menu’. Couldn’t connect to the server at 'http://localhost:5055/webhook’. Is the server running? Error: Cannot connect to host localhost:5055 ssl:default [Connect call failed (‘’, 5055)] 2021-09-10 17:46:22 ERROR rasa.core.processor - Encountered an exception while running action ‘action_menu’. Bot will continue, but the actions events are lost. Please check the logs of your action server for more information.

Hello @fatima1,

can you post the output of the execution from the action server? What it shows when starting and when the rasa core calls it…