Changes in not reflecting after rasa train

I made some changes to the file alone. ( Just changed the output of a function )

After which I ran rasa train command.

But the output I’m getting is from a previous model.(High lighted in the image given below)

I tried deleting all the models in the model folder and ran rasa train again.

But it didn’t work, still shows the old message.


Here is my github repo of code.


Hello @_sanjay_r

I am not sure if you did this, but you should restart actions server after you make changes in the file. And if you change something only in that file, you wouldn’t even need to retrain the model.

Hey @mitrovg,

I don’t understand, when the I press Ctrl + C twice, that stops the server right ?

Then I ran rasa train again, then rasa run actions -- actions actions & rasa shell --debug . Dosn’t this restart the server ?

This is also another problem I found. After I press Ctrl + C to stop the bot, The port 5005 is still open by some rasa process. I have to manually kill the process using terminal. Other wise when action action server runs, it throws an error saying port already in use, can’t bind.

Am I missing something here ?

I have the same issue, How did you resolve it?

I am not quite sure. I created a new project and set up the whole thing once more. Then the issue wasn’t arising anymore. Regarding the action server, I had to manually stop it, by checking the open ports using terminal.