'rasa run actions' is not working

After ‘rasa run actions’ it is stuck. Can anyone help?

Can you please give some more details:

  • What Rasa version are you using?
  • What error are you getting, if there is any?
  • Can you paste the log?


Mam, even am facing the same issue.

1 Like

@Ritaprava95 According to the log the action server is starting. How do you know that it is stuck? Do you see any errors? Can you also paste the debug logs here (rasa run actions --debug)?

1 Like

Hello I have installed last version of rasa recently and I have got the same problem. Could you give me a hand?

Hey, I got the same problem but i fixed it by running 2 cmd terminals. In the terminal i wrote rasa run actions and i left it open. Then I opened another cmd terminal and wrote rasa shell and everything worked fine with me.

1 Like

@Tanja The debug log:

Unable to start server Traceback (most recent call last): File “c:\users\sharms3d.conda\envs\myenv\lib\site-packages\sanic\server.py”, line 860, in serve http_server = loop.run_until_complete(server_coroutine) File “c:\users\sharms3d.conda\envs\myenv\lib\asyncio\base_events.py”, line 568, in run_until_complete return future.result() File “c:\users\sharms3d.conda\envs\myenv\lib\asyncio\base_events.py”, line 1361, in create_server % (sa, err.strerror.lower())) from None OSError: [Errno 10048] error while attempting to bind on address (‘’, 5055): only one usage of each socket address (protocol/network address/port) is normally permitted

Hi, and thanks for your time. My action server is not starting, I run rasa run actions --debug and got stuck here: 2020-05-25 17:02:40 INFO rasa_sdk.endpoint - Starting action endpoint server… 2020-05-25 17:02:40 DEBUG rasa_sdk.utils - Using the default number of Sanic workers (1).

Looks like you are running two action servers, the 5055 port is already in use.

The action server is up and running, note that the process won’t go to the background. Open another CLI start up a rasa shell and you can use your custom actions.

(rasa) E:\RASA PROJECT>rasa run actions --debug 2021-07-03 08:06:44 INFO rasa_sdk.endpoint - Starting action endpoint server… Traceback (most recent call last): File “c:\users\hp\anaconda3\envs\rasa\lib\runpy.py”, line 192, in run_module_as_main return run_code(code, main_globals, None, File “c:\users\hp\anaconda3\envs\rasa\lib\runpy.py”, line 85, in run_code exec(code, run_globals) File "C:\Users\hp\anaconda3\envs\rasa\Scripts\rasa.exe_main.py", line 7, in File "c:\users\hp\anaconda3\envs\rasa\lib\site-packages\rasa_main.py", line 117, in main cmdline_arguments.func(cmdline_arguments) File “c:\users\hp\anaconda3\envs\rasa\lib\site-packages\rasa\cli\run.py”, line 59, in run_actions sdk.main_from_args(args) File "c:\users\hp\anaconda3\envs\rasa\lib\site-packages\rasa_sdk_main.py", line 18, in main_from_args run( File “c:\users\hp\anaconda3\envs\rasa\lib\site-packages\rasa_sdk\endpoint.py”, line 138, in run app = create_app( File “c:\users\hp\anaconda3\envs\rasa\lib\site-packages\rasa_sdk\endpoint.py”, line 82, in create_app executor.register_package(action_package_name) File “c:\users\hp\anaconda3\envs\rasa\lib\site-packages\rasa_sdk\executor.py”, line 262, in register_package self._import_submodules(package) File “c:\users\hp\anaconda3\envs\rasa\lib\site-packages\rasa_sdk\executor.py”, line 225, in _import_submodules self._import_module(full_name) File “c:\users\hp\anaconda3\envs\rasa\lib\site-packages\rasa_sdk\executor.py”, line 239, in import_module module = importlib.import_module(name) File "c:\users\hp\anaconda3\envs\rasa\lib\importlib_init.py", line 127, in import_module return _bootstrap._gcd_import(name[level:], package, level) File “”, line 1014, in _gcd_import File “”, line 991, in _find_and_load File “”, line 975, in _find_and_load_unlocked File “”, line 671, in _load_unlocked File “”, line 783, in exec_module File “”, line 219, in _call_with_frames_removed File “E:\RASA PROJECT\actions\actions.py”, line 29, in class ActionAddnew(Action): NameError: name ‘Action’ is not defined

i m getting this error please someone help. on which path should I run (rasa run actions) command

Action name is not defined, be sure to import the required modules:

from rasa_sdk import Action, Tracker