Rasa and rasa x issues

Hello Rasa Community!The last two month I worked with rasa and rasa x to create bot which asks simple questions and when I worked on this project I got many errors.Here I want to share errors which I faced with and their solutions in my case

1.Rasa: Core training skipped, no valid domain files found This error occured because my domain file was in not correct format exactly there was extra whitespaces.It is hard to find extra whitespaces when domain file is big.You can use http://www.yamllint.com/

  1. Rasa: No registered actions found action_name .This error occured when I started working with custom actions.If you have same problem try one of next : 2.1.Check actions.py file to syntax errors and check the existence of your action in list of actions in domain file 2.2 Use two terminals in one run “rasa run actions” in second “rasa shell” 2.3 In endpoints.yml file uncomment this part: 1
  2. Rasa X: I deployed rasa x on server using docker-compose.https://rasa.com/docs/rasa-x/installation-and-setup/docker-compose-script/.First I installed without defining directory where I want to save rasa x and can’t find where it is installed.In my case on server there are other directories and files so if you have same case define directory with export RASA_HOME=~/rasa/dir

4.Rasa X: Wrong credentials error.In case this problem occured because I run many dockers at same time.Exactly I first created rasa project run dockers then created second project and also run dockers without stopping first

5.Rasa: Handling out of scope question. I wanted to create bot which asks my question but if it can’t find correct intent it should print “Sorry I don’t have answer to this question”.To do it I used Fallback Actions works in next way I set the threshold of core and nlu then created action_fallback action in actions.py.If percentage of prediction smaller than this threshold bot goes to action_fallback and prints “Sorry I don’t have answer to this question”

6.Rasa x: While using custom actions in rasa x ui there were many problems

6.1.I used external python library so as it is not in list of rasa_sdk libraries I created Dockerfile Deploying Your Rasa Assistant.

6.2. In my case docker-compose.override.file was in wrong directory now my directories in that form 1

6.3 After creating Docker file next commands are necessary:

6.3.1 First build image docker build . -t <account_username>/<repository_name>:<custom_image_tag>

6.3.2 Second register in DockerHub and create repository

6.3.3 Third login on terminal docker login --username <account_username> --password <account_password> 6.3.4 docker-compose pull app

6.3.5 Push image to DockerHub docker push <account_username>/<repository_name>:<custom_image_tag>

6.3.6 If you have running dockers turn off them sudo docker-compose down else turn on them sudo docker-compose up -d

6.4 The biggest error was in that I looked at endpoints.yml file which was created when I run rasa init but it does not have influence to rasa x.

Thanks to @ricwo and @athenasaurav for advices with Dockerfile. @mloubser thank you very much with correcting location of files and clarifying what should run after what!(Please recheck steps above).Sorry for my english and puctuation.I tried to explain as much as possible

1 Like

Glad you got it working @MMustafa

Hello @mloubser! Can I clarify something related to building images. I added new external libraries to Docker file then run next commands: 1.docker build 2. docker-compose pull app 3. docker push 4 docker-compose up - d. But docker compose pull app gives an error error: manifest for mustafa meruyert/rasa bot:rasa 1 not found: manifest unknown: manifest unknown.

That sounds like some issue with your dockerfile - what does it look like now?

Can you look at here.I created new thread:Connect python file to acitons.py

@MMustafa Can you please help me?