Core training was skipped because no valid domain file was found. Please specify a valid domain using '--domain' argument or check if the provided domain file exists

Hello everyone, please can anyone help me to know where is my mistake I am new in RASA this my project files (2.7 KB) domain.yml (1.4 KB)

nlu.yml (4.9 KB) rules.yml (1 Byte)

The problem is that if I run rasa train it will train only the NLU model the core is not getting trained because there is an error in my domain.yml and if i run **rasa train core ** it will give the core training was skipped because no valid domain:

Hello and Welcome @Duy please check all the syntax, I have seen there are issues in your domain file. In you rules.yml is empty, and the issue is related to your stories.yml so please cross-check that also. Please do ref this link: Training Data Format


I hope this will help and solve your issue. Good Luck!

Hi Sir, I ran my program on googlecolab instead of on the desktop environment and it worked. However, I ran into a problem when I ran the commands: rasa, it didn’t return any results. For example, when I ask the hotel within 100 meters it doesn’t return any results. These are the files: nlu, domail, stories, action (containing the activated api key) and config. can you take a look, thank you ! (2.3 KB) config.yml (622 Bytes) domain.yml (638 Bytes) (624 Bytes) (219 Bytes)

Hello @Duy. Is this related to the main issue? If your main issue is sorted, please close the thread.

@Duy how are you running the rasa and rasa action server on colab (share commands from colab/screenshot? and why do you need colab?

First, I would like to share the file structure directory running on google colab:

For , I will create a google colab file, name it rasa: this file will contain rasa install command as well as run rasa. This is all the command when I’m running rasa. This is file rasa: rasa.ipynb (44.0 KB)

This’s problem: When i run actions to querry place and result return nothing and error: ’ Encountered an exception while running action ‘action_slot’.Bot will continue, but the actions events are lost. Please check the logs of your action server for more information.’

And this all files about my project :

config.yml (622 Bytes) domain.yml (633 Bytes) endpoints.yml (57 Bytes) (503 Bytes) (202 Bytes) (2.8 KB)

@Duy if you did not tag me, you will get the late replies FYI.

As expected, please see this link and try customizing as per your rasa version and need: EmergencyChatbot/Rasa_Emergency_Chatbot_Colab.ipynb at master · claudio1975/EmergencyChatbot · GitHub

Tip: Working on local and working on Colab is different

I hope this will help you. Good Luck!

Dear Sir, Please help me, I made it

  • I have created a variable in the status_end_exam file domain.yml to assign the value true or false (true will end the test and vice versa)
  • In the stories.yml file, I have created a dialogue that, if I execute the action_speak_question_answer function and return status_end_exam = false, then render each question in the exam and if status_end_exam = false then execute uter_announce_EndExam.
  • In the file, I wrote the action_speak_question_answer function that renders a question and the answers of that question (for example, there are 10 questions, each time will return to render 1 question based on utter_speak_QuestionAnswer) However, current_question did not increase to render the next question but only stopped at sentence 1 nlu.yml (2.3 KB) domain.yml (3.4 KB) stories.yml (4.6 KB) (5.8 KB)

The problem: I want to repeat the action many times

@Duy can we have a quick call? I am trying to understand your use case. I don’t have much time to run the code.

yes, i can contanct on skype ? This is my skype: live:.cid.83dd6a38cbb4e894 Can u contanct me everytime, i really help from u

it means, this is example about stories:


Action: Call to get Data from my exam ( Exam has: 3 three question, each question which there 4 four answer with label a,b, c or d) → save: global data = data_exam

Intent: User say start_exam (say: “start exam”)

Action: call to to get each question with four answers from varible global data is save. global[0] with ( Question 1: 1 + 1 = ? with result: a.1 , b.2 , c.3 ,d.4) = slot_set (‘question_answer’)

Action: utter_render_question (slot_set question_answer) → Question 1: 1 + 1 = ? with result: a.1 , b.2 , c.3 ,d.4

Intent: User choose answer with label a

Action: check answer of user and return result ( you are right, the answer is correct)

And now, i want to continue with question 2, but i cant do with loop - , reapt the action render question_answer until the question 3.

domain.yml (3.4 KB) Dear Sir, Dear Sir, Yes, I’ll send you the part I’m working on and the problems I’m having! My current topic is to get the questions in an exam for the user to test. I made a bot according to the Vietnamese recognition part

  1. Part 1, the structure does:
  • config.yml, do you use default library to recognize Vietnamese, can you please take a look and help me

Pic: config.yml

Pic: nlu.yml

Pic: domain.yml

In this file domain.yml, I have created a slot set with form of status_end_exam, my wish is that when it is true, I will not render the question from the test anymore, and if it is false, I will continue to execute the question rendering loop.

Pic: stories.yml

I have bolded the part I can’t do, after each time I want to redo the question rendering until the end of the exam. In the file, I have created a global variable to increase the number of questions myself. and problem: when i say intent: start_exam, the action alway return nlu.yml (2.3 KB) rules.yml (131 Bytes) stories.yml (3.6 KB) uttter_default


I am not on Skype sorry. You share me your Gmail ID or we can setup the zoom call.

Yeah Sir, I am really happy from your help, but i sloved my problem. It is a error in my function in Thank you Sir

happy you solved your issue please close this thread.