Core training was skipped because no valid domain file was found v

Hello please can anyone help me to know where is my mistake I am new in RASA this my project files (1.7 KB) nlu.yml (3.3 KB) rules.yml (541 Bytes) stories.yml (2.4 KB)

@Ahmad-Alkhuder can you share the full error traceback, with the screennshot? and also the rasa --version for the reference?

(please help me to finish this project I have bee trying since 7 days but it’s not working​:tired_face::disappointed_relieved:) The problem is that if I run rasa train it will train only the NLU model the core is not getting trained because there is an error in my domain.yml and if i run **rasa train core ** it will give the core training was skipped because no valid domain file was found like this :

The rasa version which i am using : After i run rasa train : Annotation 2022-03-10 004435

The error says the domain wasn’t found, and you shared all the files except the domain.

Do you even have a domain.yml file?

oh i am really sorry domain.yml (4.0 KB)

1 Like

Can you try with this file?

domain.yml (4.0 KB)

I am studying from this course on Udemy and i want this project to work in my Rasa version but it’s not happening

Thank you so much for helping me

i got this error and if i delete - same previous error comes

1 Like

Oh oops! I added a space by mistake

Please replace | - with |- on line 126 and try again

It works the previous error is still there

1 Like

Oh man… I can’t find what the error is…

Try to remove each element one by one and check if the error stays :sweat_smile:

Ohh , its okay , Thank you so much . Actually i tried this but i couldn’t find the error

1 Like

Oh there’s a typo!

On line 22, you wrote entites instead of entities

Oh the error behind rasa core not being trained is i added one action utter_ask_exercise twice in the Actions list in domain file . and the typo what you mentioned is also there . Thank you so much

1 Like


So it’s solved now?

Yes it’s solved but the form is not working it’s displaying the slots directly

This is another issue, please close this thread and open another one :slight_smile: