No module named 'slack'

Hi everyone, I’m new in rasa, when I run rasa init, I go"t this error : " No module named ‘slack’

Does anyone know how to fix it? thanks.

Hello halohalo! Welcome to the forum.

It would help to know a bit more about your environment… What operating system are you using? How did you install Rasa? Which version are you using? And could you post the complete error message?


Can you also provide the full output from the rasa init.

I fixed the problem already and thanks :slight_smile:

Hi, Can you share the solution to fix the issue? Python version - 3.7.9 I am also getting the same error -

Traceback (most recent call last): File “/home/sunil/anaconda3/envs/rasachatbot/bin/rasa”, line 8, in sys.exit(main()) File “/home/sunil/anaconda3/envs/rasachatbot/lib/python3.7/site-packages/rasa/”, line 91, in main cmdline_arguments.func(cmdline_arguments) File “/home/sunil/anaconda3/envs/rasachatbot/lib/python3.7/site-packages/rasa/cli/”, line 76, in train additional_arguments=extract_additional_arguments(args), File “/home/sunil/anaconda3/envs/rasachatbot/lib/python3.7/site-packages/rasa/”, line 50, in train additional_arguments=additional_arguments, File “uvloop/loop.pyx”, line 1456, in uvloop.loop.Loop.run_until_complete File “/home/sunil/anaconda3/envs/rasachatbot/lib/python3.7/site-packages/rasa/”, line 101, in train_async additional_arguments, File “/home/sunil/anaconda3/envs/rasachatbot/lib/python3.7/site-packages/rasa/”, line 188, in _train_async_internal additional_arguments=additional_arguments, File “/home/sunil/anaconda3/envs/rasachatbot/lib/python3.7/site-packages/rasa/”, line 223, in _do_training additional_arguments=additional_arguments, File “/home/sunil/anaconda3/envs/rasachatbot/lib/python3.7/site-packages/rasa/”, line 361, in _train_core_with_validated_data additional_arguments=additional_arguments, File “/home/sunil/anaconda3/envs/rasachatbot/lib/python3.7/site-packages/rasa/core/”, line 33, in train from rasa.core.agent import Agent File “/home/sunil/anaconda3/envs/rasachatbot/lib/python3.7/site-packages/rasa/core/”, line 22, in from import InputChannel, OutputChannel, UserMessage File “/home/sunil/anaconda3/envs/rasachatbot/lib/python3.7/site-packages/rasa/core/channels/”, line 24, in from rasa.core.channels.slack import SlackInput # nopep8 File “/home/sunil/anaconda3/envs/rasachatbot/lib/python3.7/site-packages/rasa/core/channels/”, line 11, in from slack import WebClient ModuleNotFoundError: No module named ‘slack’

1 Like

I am also getting same error when try to create project using “rasa init --no-prompt”

File anaconda lib path lib\site-packages\rasa\core\channels\, line 18, in from slack import webclient ModuleNotFoundError: No module named ‘slack’ I am trying this on anaconda command prompt. Can someone suggest here.