Rasa init _ modulenotfounderror

I have been trying to create a RASA bot myself, however, after having installed all the necessary modules and dependencies, the moment I do rasa init , I get the following error :-

Preparing transaction: done
Verifying transaction: done
Executing transaction: done

(rasa) C:\Users\my\Desktop\My RASA Chatbot>rasa init
Traceback (most recent call last):
  File "c:\users\my\anaconda3\envs\rasa\lib\runpy.py", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "c:\users\my\anaconda3\envs\rasa\lib\runpy.py", line 85, in _run_code
    exec(code, run_globals)
  File "C:\Users\my\Anaconda3\envs\rasa\Scripts\rasa.exe\__main__.py", line 7, in <module>
  File "c:\users\my\anaconda3\envs\rasa\lib\site-packages\rasa\__main__.py", line 82, in main
  File "c:\users\my\anaconda3\envs\rasa\lib\site-packages\rasa\utils\common.py", line 71, in set_log_level
  File "c:\users\my\anaconda3\envs\rasa\lib\site-packages\rasa\utils\common.py", line 112, in update_tensorflow_log_level
    import tensorflow as tf
ModuleNotFoundError: No module named 'tensorflow'

PS : I have uninstalled Tensorflow and re-installed using conda. I have also tried downgrading & upgrading tf to try my luck. I am not sure what has gone wrong abruptly, as when I tried doing it the first time, the environment setup, rasa installation, activation and initialization , etc. was all seamless.

Welcome Shivam,

We recommend doing this under venv. Have you gone through the Windows install steps here?