No module named rasa_nlu.train

Hello friends, I have been getting an error when i run the following command.

Command: python3 -m rasa_nlu.train -c /Users/manojkumarteluguntla/Downloads/nlu_config.yml --data /Users/manojkumarteluguntla/Downloads/nlu.md -o models --fixed_model_name nlu --project current --verbose

Can someone help me out. I am very much new to Python, RASA Stack and Machine learning. just started my career in ML.

Hey @Teluguntla123. Any chance you have another version of python installed on your machine besides python 3?

Yes. python 2.7 was also installed before. But now I uninstalled it. Now I got that error resolved.

Thanks so much for your reply.

Now I am facing other problem. Can you help me out in solving that issue.

That’s what I thought - rasa_nlu was probably installed amongst the python 2.7 packages. Glad to hear the issue is now gone.

Sure! Let me know what’s the issue :slight_smile:

I have installed RASA NLU and RASA CORE and their dependencies as per shown in Rasa NLU: Language Understanding for chatbots and AI assistants. I created data files and configuration files for botg rasa nlu and rasa core and trained them individually.

These are the files I created as it is in the documentation without any changes. nlu_config.yml, nlu.md for rasa_nlu domain.yml, stories.md for rasa core.

I trained RASA NLU and RASA CORE with the commands mentioned in the documentation. It is not working properly, when I tried to combine or integrate both NLU and CORE.

when I executed this command:

python -m rasa_core.run -d models/dialogue -u models/current/nlu

My chatbot is up and running but it is not responding to my text messages. I attached the screenshot of my results. please find them. please let me if you need more information to solve this issue.

Hey. I tried reproducing everything using the files provided in Rasa Stack quickstart and everything seems to be working as expected.

I am not exactly sure what is the issue that you are facing because you did get the response to hello message. Do you mind sharing your what nlu and stories data are you using? My guess is that it has too little examples and simply makes a mistake when predicting the next action.

Firstly, Thanks for your response.

Sure, I am sending all my configuration files and data files. These are the four files which I have used to train NLU and CORE. All the data in these files are same as mentioned in the examples of the documentation. please let me know if you need anything else.

Yes, I am getting response only for “hello” message, which means either NLU or core were trained only for one single message.

domain.yml (486 Bytes)

nlu.md (663 Bytes) nlu_config.yml (43 Bytes) stories.md (365 Bytes)