No continuous response from the bot even when custom action server is running

Hi @Juste , @akelad ,@tmbo,

I have created a weather bot similar to weather bot by Justina Petra[Latest%20release%20of%20Rasa%20NLU%20and%20Rasa%20Core]

(using the latest versions of rasa-nlu and rasa-core). My major problem is that when the bot is loaded,it gives the response (which is the weather of a particular location) but most of the times it does not give any response at all,even though the action server is up and running. I’m not able to figure out what is causing the issue. Attaching the screenshot of the response i get when the bot is loaded…

Please help me in resolving this issue …

Is this happening only when you enter certain places or for every place this happens?

For any location … For example,it gives response for the first time and it won’t give any response after that. But once in a while it gives response in the 1st and 2nd attempt but won’t respond after that…

Not able to figure out what is causing the issue

can you share your custom action file?

So it’s saying that this error is caused by older version of numpy library! can you try upgrading?

pip install numpy==1.14.5

I don’t think the numpy library is the issue. This error has always been there for me and it has nothing to do with the bot function.

How many stories do you have?

Take a look, not sure bot will be affected by this

I’m using numpy version 1.15.0

try pip install numpy==1.14.5 it won’t harm anything just try if doesn’t work you can go back to older version

20 stories,I tried adding more…but issue remained the same

If you see the picture above, the first time the bot gave a response but the numpy error still exists so I don’t think that is the issue.

@Prabha Can you add this as a separate story and check again?

## weather
* inform[location=Italy]
  - slot{"location": "Italy"}
  - action_weather

In the picture above, you were asking for the location multiple times but the stories don’t follow this pattern, it could be possible that the bot did not find a suitable story and hence it’s just listening. Does this error occur even if you follow the pattern in the stories?

@srikar_1996, There is no specific pattern in which the bot responds. For instance,it wont respond in the first attempt itself for the same piece of code which gave response earlier.

Hmmm… Another possibility could be that the place isn’t getting recognized. Are you using spacY? If yes, use the link below to see what place entity it is able to capture. When I checked, it isn’t capturing chennai and mumbai as places. ALso, the case of the words matter for spacy.

No it’s not about the place.I’ve tried it. Moreover I have this weather bot using spacy with older version of rasa. It worked pretty well with different locations. Once I upgraded to version 11 of rasa(took the help from @Juste weather bot using latest version of rasa) ,this issue came up and I’m not able to resolve

Hey @Prabha. It is very likely that the location simply doesn’t get recongised. It’s simply because the amount of training data I included in this tutorial is very small. I would suggest adding a bit more training examples to your nlu and maybe stories data and see how it performs.

Just one more ting: do you get any errors on the action server when the bot stops responding? If yes, can you share them here?

I don’t think even the bot is listening… because it should show some or the other response in the terminal where I run the action server…but it’s completely blank when there is no response while running the bot

1 Like

No error at all.My main problem is that… If at all there is an error,it should not respond at all. But here,it gives response(the weather details) in first attempt,second attempt…and stops giving response all of a sudden. In other cases,in the first attempt itself it won’t give any response… All these things are happening for the same piece of code. I’m unable to resolve this issue…Requesting ur help @Juste

1 Like

On a side note, the code you posted has your personal API key. Others will be able to access the APIs with this. It’s better if you delete this comment and change your key so it’s not available to others.

Hi @Juste, The weather bot I’ve created worked perfectly fine with older version of RASA.I have tested with different locations.No problem at all. Now that I’ve upgraded RASA to version11 and made changes according to ur weather bot tutorial (using latest versions of RASA),this issue is popping up

1 Like