Bot returns an empty array as response when trying to hit through postman (works fine on commandline)

Hi @tmbo, @akelad,@Juste , Ive created a weatherbot based on Justina’s weatherbot tutorial.It worked fine with version 7 of RASA,after migrating it to version 13 it was giving empty list as response whenever i tried to hit from the postman… P.S :I made all the necessary changes according to the migration docs available. @tmbo I have raised this issue multiple times both in github and RASA forums,but i never get any reply to this. This is the only problem which is impending me from integrating my bot with UI…Any help is appreciated…

Im attaching the error_screenshot

hey @Prabha you need to send the request in this format : { “sender”: “Rasa”, “message”: “Hi there!” } can you tell me which API are you using?

@JiteshGaikwad I have sent the request in the same format only… Actually my problem is that it used to work fine with version 7 of RASA.After upgrading it to version 13,it’s giving an empty list as a response. All the API’S like respond,weather api are giving the same [] response.

P.S:: I tried to give the same request on a different system which used version 7 of RASA,there it’s giving me the response correctly.Only on my PC which has version 13 it’s giving [] as a response. So I can said that it’s definitely not the format error or sth to do with API also if I’m not wrong…

hey @Prabha, just try out Rest input and check

Hi Prabha.

I am also looking for the similar stuff. Can you see my post on this issue.