Install rasa-x issue

i installed rasa x but when im traying to launch it i got this error

@mglall Hello, please can you share your rasa version while using rasa --version ?

sure here it is!

@mglall did you run the command rasa init before running rasa x?

@mglall are you able to chat with bot or its opening in your default web browser?

i used rasa x in my pretrained project however i created a new one to see if rasa working properly, here is a full log of the all process :slight_smile:

@mglall are you able to chat with bot (rasa-x) or its opening in your default web browser??? Yes or No?

no its not opening on the browser

@mglall can you delete the cookies and data from the web browser and try run please?

@mglall If you still not able to run rasa x and you not able to see chat screen in default then, I will share the alternative solution for that :slight_smile:

ok will do it appreciate your help

i cleared the browser cookies and data but still the same

@mglall Right, as expected

I’d recommend to create a fresh conda environment with python 3.8 and follow the step

`pip install rasa==2.8.1`
`pip install rasa-sdk==2.8.1'

check version rasa --version its install or not


pip install rasa-x==0.39.3 --extra-index-url

check rasa version rasa --version its install or not

You will see some error : ImportError: cannot import name ‘RowProxy’ from ‘sqlalchemy.engine’ Install

pip install SQLAlchemy==1.3.22 should fix it

If sanic related error: pip install sanic-jwt==1.6.0

delete .db if is showing alembic issue.

Good luck! I hope this will solve your issue. Please try now and do let me know please. Please mention @ and nik202

1 Like

@nik202 thank you i have been in this situation for about a month now the issue has been resolved by exactly the same instructions you provided thanks again

@mglall Ohh really, you should post way back then :slight_smile:. No worries happy to help you!