Run rasa x Error

my rasa version

@m0001123 welcome on the forum :bouquet:

Please install Anaconda from Anaconda | Individual Edition , then create the conda environment using the following command

  1. conda create -n rasa3 python=3.8
  2. conda activate rasa 3

Note: I’d recommend to create a fresh environment if not you can proceed with next steps:

For Rasa Open Source:

`pip install rasa==2.8.1`
`pip install rasa-sdk==2.8.1'

check version rasa --version its install or not

For Installing basic project:

rasa init

then if you need

For Rasa-X Installation

pip install rasa-x==0.39.3 --extra-index-url

check rasa version rasa --version its install or not

You will see some error : ImportError: cannot import name ‘RowProxy’ from ‘sqlalchemy.engine’ Install

pip install SQLAlchemy==1.3.22 should fix it

If sanic related error: pip install sanic-jwt==1.6.0

delete .db (events and rasa ) if is showing alembic issue.

If you have any error in-between please share with us.

I hope this will solve your issue.

still the same

@m0001123 can you share rasa --version while activating environment ?

@m0001123 create a project folder now and install rasa init and first run rasa shel --debugl ; talk to your bot (moodbot) and share the screenshot with me. @m0001123 please mention me with @ and nik202

@nik202 run rasa init is ok

run rasa x error

@m0001123 can you try this? pip install --force --upgrade scrapy

@m0001123 even I’d encourage to delete the previous install anconda3, download again , re-install and then create the environment, and follow the process.

this is very strange error for us.

@nik202 ok ,let me try it

@m0001123 Sure, and let me know please. Make sure you met all dependencies if encountered.

@nik202 can you help me

@m0001123 after which command this error shown?

@nik202 pip3 install rasa-x — extra-index-url Simple Index

@nik202 tried again and it’s still the same

@m0001123 I think you not seen my solution steps? please see it again Run rasa x Error - #3 by nik202

If you used a wrong command then you see such errors.

@m0001123 I stated this command:

pip install rasa-x==0.39.3 --extra-index-url

@nik202 OK but I have a new Error

cannot import name ‘RowProxy’ from ‘sqlalchemy.engine’

@m0001123 install this please

pip install SQLAlchemy==1.3.22