How will Rasa-x intent and response changes reflect in rasa core in docker container?


Rasa and rasa-x are installed on docker container on server and i made few changes in rasa-x UI like added intents, its examples, responses and trained the model in UI and tried running interactive learning and everything is working fine. domain.yml also shows newly added intents and responses in rasa-x UI. i am using rasa latest version 2.0

Now while i am checking domain.yml in rasa core, newly added intents and responses don’t reflect here in rasa core. Please note that i am not created or connected to git repository and checking only rasa folder structure on server only.

Do i need to run any specific command to get these reflected in core? where i am doing wrong?

Thanks and Regards

Can you help me understand where this rasa core that you’re referring to is running?

In general, no data or domain “live” in Rasa, they live in either a file system or a database that Rasa and Rasa X are aware of.

Are you running Rasa X via docker-compose? If so, there is no separate “Rasa core”, there are two Rasa Open Source (which includes both core/dialogue management & NLU) containers that get started to support Rasa X. If so, how did your data get into Rasa X? Via integrated version control, or by another method?

Hi, Thanks for your response. yes its running through docker-compose and while exploring rasa core folder structure i observed that files which we can edit in rasa-x are not in rasa folder and i assume those needs to be editing through rasa-x UI.

No i am not using git version control so its picking base rasa model from docker itself.

My understanding is - following files needs to be editing thru Rasa-x UI like nlu.yml, domain.yml, config.yml, rules and stories.

actions file i could not find anywhere to create custom actions.

Now i tried creating forms and slots thru rasa-x by updating domain.yml and rules but its not working

I’m still not sure where is this “rasa core” - rasa_core is an outdated python package, replaced by the overall rasa package, which runs in both rasa_production and rasa_worker containers. Where are you going, what commands are you running, to look for your domain?

I might seem confusing. yes you are right … now rasa core is outdated and replaced by rasa_production and rasa_worker containers. Now like if i installed it in etc/rasa on server using docker container… i checked in that folder directly the folder structure.

I hope its clear now.

Ok. I think you may have understood the deployment slightly incorrectly. The rasa-x container is not the same as the “Rasa X” application. Rasa X is composed of multiple microservices - it would be helpful to look at the architecture page and read through the services/containers descriptions.

1 Like

As you can see on that docs page and in the image I copied in here, your git repository is intended to be the source of training data you see in Rasa X. This training data will also reflect in the SQL DB. If you are simply creating training data in Rasa X, and not connecting the instance to a git repository, the data only lives in the SQL DB. That is not great, because now you cannot version your changes. Step 1 would be to connect a git repository (even if it is initially a very minimal bot) to the instance, so that you can push your changes.

You should not ever need to go fetch data from the file system inside the rasa-x container.

Ohh ok… got it… This diagram will surely help me understand the flow and architecture. Actually currently my organization don’t allow me to connect to git so i have to work with it for now.