How to restore training data

Hi I’ve been working on a project for a while now, when trying to deploy it using docker, I used the init command which rewrote all my training data (stories, rules, nlu, and domain) and actions folder All I have is the last model I trained, would it be possible to restore some training data from the model itself?

@Yasser-Mah means you are using rasa init command in Docker deployment?

The exact command I used is docker run -v %cd%:/app rasa/rasa:3.0.8-full init --no-prompt in my project folder.

@Yasser-Mah ok means you are running this command every time, still, if you created the image once??

Sorry I don’t understand what you mean exactly,

I developed a chatbot over the last two weeks and never used any docker commands on it, I tried to deploy it today and messed up by using that command because it reset all my files to the default project.

All the files have been reset except for the models file.

means today you tried to deploy your project using docker? and you lost all your data as it’s overwritten with the basic rasa project? and you want to retrieve your data? yes or no?


@Yasser-Mah I am afraid you can not, but maybe you can find the domain.yml I guess again.


Do you have a training model in .tar.gz

@Yasser-Mah confirm with me it’s trained with Rasa 2.x or 3.x ?

I have a trained model in .tar.gz,

I am using Rasa 3.x

I tried extracting the model.tar.gz and I have found the domain_provider file which has my domain.yml.

that’s all I can recover?

@Yasser-Mah I’m afraid so :frowning:

Thank you for the confirmation :frowning: . I just wanted to make sure.

@Yasser-Mah always push your code to Github for the safer side and always perform the experiment on the copied data. I can relate when you lose the data on which you have spend a lot of time :frowning: (

Can I request to please close this thread with a solution and reference for others?. Thanks

1 Like