Rasa Docker problem with training the model

Hi,

I’m following this tutorial: Running Rasa with Docker

I’ve done this lines:

docker run -v $(pwd):/app rasa/rasa init --no-prompt image

docker run -it -v $(pwd):/app rasa/rasa shell

This one doesn’t wait for my input and finishes immediatly?

docker run \ -v $(pwd):/app \ rasa/rasa:latest-full \ train \ --domain domain.yml \ --data data \ --out models

Only this happens and new model doesn’t get trained/created?

Does anyone know why?

Anyone?

If you are running the server with the third one

docker run \ -v $(pwd):/app \ rasa/rasa:latest-full \ train \ --domain domain.yml \ --data data \ --out models

and you are seeing the model not being trained, can you

docker exec -it <container> bash

and see if the model was created inside the container?

Alternatively, can you try providing the full path to your project directory instead of $(pwd)?

erohmensing I have tried now running this line from the image first and underneath is the result of 20 minutres training:

After this trained I entered the container with: "docker exec -it CONTAINTER_NAME /bin/bash

and positioned myself into the model folder but there is no new trained model there…

Usually when I train locally my two last lines are underneath and they are missing after my initial training.

“2020-02-14 10:39:54 INFO rasa.nlu.model - Finished training component. 2020-02-14 10:39:55 INFO rasa.nlu.model - Successfully saved model into PATH”

Any ideas?

Someone?

I’m having the same issue . No model found after running the command:

docker run
-v $(pwd):/app
rasa/rasa:latest-full
train
–domain domain.yml
–data data
–out models So I tried to inspect what’s going on . I ran the container and tried to train it manually and Now I got a segmentation fault error.

the training hasn’t been completed , that’s why i couldn’t find the model and now i don’t know how to fix the issue ? any help is welcomed . thnx

I still haven’t solved this either…

erohmensing tyd

Hey, see this next topic :

1 Like

@vivitare thanks . it helped a lot to debug and understand the issue . At the end , I chose to build my image inspired from what I found on Rasa’s website and the community . For now everything is working perfectly and the containers are orchestrated . Here’s the link Rim Ben Nasr / rasa docker · GitLab . Hoping it could help someone else .

2 Likes

Thank you for sharing @rimbns but I get this error when I run your Dockerfile:

It is same one as I described here:

Can you help?

Sorry rasafan for my very late reply , I’ve been busy last few days.

I didn’t run through this problem before and according to the internet they say that the errors occurred cause the apt repositories are configured incorrectly. So I guess the problem is coming from the base image (python:3.7). before running the Dockerfile , try to download the image

sudo docker pull python:3.7

besides make sure that you are connected to internet while running the Dockerfile .

good luck