Failure in Installing RASA X (Refering the masterclass: E-Book)


I am trying to train a chatbot, following the RASA master class, at episode 9 I was supposed to install the Rasa X and train the bot. All other steps such as pushing to github and setting up VM in google cloud is done.

But when I tried to run the below commands I faced an error- curl -sSL -o And then I run the command - sudo bash ./

I have used the latest Rasa X version - 0.32.2

The problem is no folder was crated for Rasa X, moreover when I run the above code few errors came. I am attaching a screenshot of the same as well.

Please let me know how can I Install Rasa X, I was training a chatbot which I can use for my e-commerce website. It means alot. Thanks in advance .

Try using Quick Install Script instead.

curl -s | sudo bash

This is the recommended way of deploying rasa at the moment. It is not mentioned in masterclass videos. You can find more information here.

1 Like


Thanks alot gaurav. I have just set the VM in google cloud, and now will run the above command there. The link you shared took me to many other resources. Thanks!