Rasa X Model Training Failed

Hello! Hope you are well!

I am encountering a problem in setting up Rasa X. I have deployed the latest version of Rasa-X with Rasa 2.4 on Google cloud platform, and I have connected it to my git repo. I can see my stories and intents in my dashboard, however, my using the ‘train a model’ option is returning a failure message with no further explanation. I can train and interact with the model when I do so in terminal from my local machine. I am not sure how to proceed.

My credentials file, I’ve tried the default Rasa url and the url where my Rasa-X instance is hosted on the cloud, neither have worked.

#  # you don't need to provide anything here - this channel doesn't
#  # require any credentials

#  user_message_evt: <event name for user message>
#  bot_message_evt: <event name for bot messages>
#  session_persistence: <true/false>

# This entry is needed if you are using Rasa X. The entry represents credentials
# for the Rasa X "channel", i.e. Talk to your bot and Share with guest testers.
  url: "http://localhost:5002/api"

@arabellastrange can you tell me the rasa x version and installation method?

I’m using Rasa X 1.0.1 which I installed using REI (curl -O https://rei.rasa.com/rei.sh && bash rei.sh -y) on GCP Compute Engine.

@arabellastrange please investigate the nlu.yml file or domain.yml file syntax with respect to Git and shown in Rasa X. If there is any mismatch model will not train.

Tip: Some issues you will see in domain.yml top header in blue if you have some?

@arabellastrange Always tag me as I am not active on the forum much now.

Good Luck!

Thanks for the reply @nik202, I have made some commits to check and my git repo and Rasa X seem to be appropriately synced! My domain and nlu files seem to be correct as far as I can see?

@arabellastrange alright as expected, please update as per compatibility matrix: Compatibility Matrix

i.e 2.8.x can be 2.8.11 or 2.8.15

@nik202 is there a way to downgrade RASA X instead with the REI? I have another dependency that is only compatible with RASA 2.4.

@arabellastrange what do you exactly mean?

@nik202 I mean I would like to replace my Rasa X 1.0.1 installation with Rasa X 0.38.0, but I cannot find the documentation for setting versions when installing with the Rasa Ephemeral Installer.

@arabellastrange why do you want to downgrade to a lower version? In the lower version, you will not able to get the git connectivity feature. If you still want to install please follow this link : Rasa X runs with several Errors & Warnings - #7 by vio_lovis

Do tag me if you have any issues. Good luck!

@nik202 this version of webchat only supports up to Rasa 2.4 does it not? Therefore, I need an older version Rasa X as well.

@arabellastrange no it will support all versions 1.x, 2.x, and 3. x Rasa open source. But Rasa X 1.0.1 is not yet compatible with Rasa 3.x OS

@arabellastrange I would recommend using rasa x 0.42.5 with rasa open source 2.8.11 or 2.8.15

@nik202 Oh, I see, I assumed because the repo had not been updated recently, it would not be compatible, I will try this set up and let you know!

@nik202 unfortunately, my problem is persisting. I have now set my version of Rasa X to 0.42.6 in my cloud instance, my open source Rasa version is 2.8.14 and my Rasa SDK is 2.8.3. I can still train and interact with my project locally and my git repo and Rasa X are synced correctly, but I can’t train models in Rasa X or upload trained models either. Not sure how to proceed?

@arabellastrange if you have install rasa x 0.42.6 and I guess you don’t have action server image yet ( its fine we can sort that issue later) but current issue can have two possibilities.

  1. Your git code and rasa x code is not synchronised? Solution: Delete all the keys and add again and connect git with rasa x
  2. Check the syntax of domain.yml which you pushed and domain.yml code which is present in rasa x

Or share some more screenshots.

It is very hard for me to guide you.